rubygem-puma-3.11.4-1.fc29.x86_64.rpm


Advertisement

Description

rubygem-puma - A simple, fast, threaded, and highly concurrent HTTP 1.1 server

Property Value
Distribution Fedora 29
Repository Fedora x86_64
Package filename rubygem-puma-3.11.4-1.fc29.x86_64.rpm
Package name rubygem-puma
Package version 3.11.4
Package release 1.fc29
Package architecture x86_64
Package type rpm
Homepage http://puma.io
License BSD
Maintainer -
Download size 78.95 KB
Installed size 221.71 KB
A simple, fast, threaded, and highly concurrent HTTP 1.1 server for
Ruby/Rack applications.

Alternatives

Package Version Architecture Repository
rubygem-puma-3.11.4-1.fc29.i686.rpm 3.11.4 i686 Fedora
rubygem-puma - - -

Requires

Name Value
/usr/bin/ruby -
libc.so.6(GLIBC_2.14)(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libruby.so.2.5()(64bit) -
libssl.so.1.1()(64bit) -
libssl.so.1.1(OPENSSL_1_1_0)(64bit) -
rtld(GNU_HASH) -
ruby(rubygems) -

Provides

Name Value
rubygem(puma) = 3.11.4-1
rubygem-puma = 3.11.4-1.fc29
rubygem-puma(x86-64) = 3.11.4-1.fc29

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package rubygem-puma-3.11.4-1.fc29.x86_64.rpm
Source Package rubygem-puma-3.11.4-1.fc29.src.rpm

Install Howto

Install rubygem-puma rpm package:

# dnf install rubygem-puma

Files

Path
/usr/bin/puma
/usr/bin/pumactl
/usr/lib/.build-id/
/usr/lib/.build-id/dd/5ada62dd0e17d0cf7b3df70553d51f01ec5f07
/usr/lib64/gems/ruby/puma-3.11.4/gem.build_complete
/usr/lib64/gems/ruby/puma-3.11.4/puma/puma_http11.so
/usr/share/gems/gems/puma-3.11.4/LICENSE
/usr/share/gems/gems/puma-3.11.4/bin/puma
/usr/share/gems/gems/puma-3.11.4/bin/puma-wild
/usr/share/gems/gems/puma-3.11.4/bin/pumactl
/usr/share/gems/gems/puma-3.11.4/lib/puma.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/accept_nonblock.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/binder.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/cli.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/client.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/cluster.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/commonlogger.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/compat.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/configuration.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/const.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/control_cli.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/convenient.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/daemon_ext.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/delegation.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/detect.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/dsl.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/events.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/io_buffer.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/java_io_buffer.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/jruby_restart.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/launcher.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/minissl.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/null_io.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/plugin.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/rack_default.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/reactor.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/runner.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/server.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/single.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/state_file.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/tcp_logger.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/thread_pool.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/util.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/app/status.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/plugin/tmp_restart.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/rack/builder.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/rack/urlmap.rb
/usr/share/gems/gems/puma-3.11.4/lib/puma/rack/backports/
/usr/share/gems/gems/puma-3.11.4/lib/puma/rack/backports/uri/common_193.rb
/usr/share/gems/gems/puma-3.11.4/lib/rack/
/usr/share/gems/gems/puma-3.11.4/lib/rack/handler/puma.rb
/usr/share/gems/specifications/puma-3.11.4.gemspec

Changelog

2018-05-29 - Pavel Valena <pvalena@redhat.com> - 3.11.4-1
- Update to puma 3.11.4.
2018-02-09 - Fedora Release Engineering <releng@fedoraproject.org> - 3.11.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2018-01-20 - Björn Esser <besser82@fedoraproject.org> - 3.11.0-2
- Rebuilt for switch to libxcrypt
2018-01-04 - Vít Ondruch <vondruch@redhat.com> - 3.11.0-1
- Update to Puma 3.11.0.
2018-01-04 - Vít Ondruch <vondruch@redhat.com> - 3.10.0-4
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.5
2017-08-21 - Jun Aruga <jaruga@redhat.com> - 3.10.0-3
- Skip unstable test.
2017-08-21 - Jun Aruga <jaruga@redhat.com> - 3.10.0-2
- Fix for unstable test.
2017-08-18 - Jun Aruga <jaruga@redhat.com> - 3.10.0-1
- Update to Puma 3.10.0.
2017-08-09 - Jun Aruga <jaruga@redhat.com> - 3.9.1-1
- Update to Puma 3.9.1.
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 3.8.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

See Also

Package Description
rubygem-puma-doc-3.11.4-1.fc29.noarch.rpm Documentation for rubygem-puma
rubygem-pundit-1.0.1-6.fc29.noarch.rpm Object oriented authorization for Rails
rubygem-pundit-doc-1.0.1-6.fc29.noarch.rpm Documentation for rubygem-pundit
rubygem-puppet-lint-1.1.0-2.fc23.noarch.rpm Ensure your Puppet manifests conform with the Puppetlabs style guide
rubygem-puppet-lint-doc-1.1.0-2.fc23.noarch.rpm Documentation for rubygem-puppet-lint
rubygem-qpid_messaging-1.38.0-2.fc29.x86_64.rpm Ruby bindings for the Qpid messaging framework
rubygem-qpid_messaging-doc-1.38.0-2.fc29.noarch.rpm Documentation for rubygem-qpid_messaging
rubygem-qpid_proton-0.24.0-1.fc29.x86_64.rpm Ruby language bindings for the Qpid Proton messaging framework
rubygem-qpid_proton-doc-0.24.0-1.fc29.noarch.rpm Documentation for rubygem-qpid_proton
rubygem-rabbit-2.2.1-4.fc29.noarch.rpm RD-document-based presentation application
rubygem-rabbit-doc-2.2.1-4.fc29.noarch.rpm Documentation for rubygem-rabbit
rubygem-rabl-0.11.0-7.fc29.noarch.rpm General Ruby templating with JSON, BSON, XML and MessagePack support
rubygem-rabl-doc-0.11.0-7.fc29.noarch.rpm Documentation for rubygem-rabl
rubygem-racc-1.4.14-10.fc29.x86_64.rpm LALR(1) parser generator
rubygem-racc-doc-1.4.14-10.fc29.noarch.rpm Documentation for rubygem-racc
Advertisement
Advertisement