php-symfony-options-resolver-2.8.51-1.fc29.remi.noarch.rpm


Advertisement

Description

php-symfony-options-resolver - Symfony OptionsResolver Component

Property Value
Distribution Fedora 29
Repository Les RPM de Remi i386
Package filename php-symfony-options-resolver-2.8.51-1.fc29.remi.noarch.rpm
Package name php-symfony-options-resolver
Package version 2.8.51
Package release 1.fc29.remi
Package architecture noarch
Package type rpm
Homepage http://symfony.com/doc/2.8/components/options_resolver.html
License MIT
Maintainer -
Download size 21.43 KB
Installed size 53.80 KB
The OptionsResolver Component helps you configure objects with option arrays.
It supports default values, option constraints and lazy options.

Alternatives

Package Version Architecture Repository
php-symfony-options-resolver-2.8.51-2.fc29.remi.noarch.rpm 2.8.51 noarch Les RPM de Remi
php-symfony-options-resolver-2.8.51-2.fc29.remi.noarch.rpm 2.8.51 noarch Les RPM de Remi
php-symfony-options-resolver-2.8.51-1.fc29.remi.noarch.rpm 2.8.51 noarch Les RPM de Remi
php-symfony-options-resolver-2.8.51-1.fc29.noarch.rpm 2.8.51 noarch Fedora Updates
php-symfony-options-resolver-2.8.51-1.fc29.noarch.rpm 2.8.51 noarch Fedora Updates
php-symfony-options-resolver-2.8.45-1.fc29.noarch.rpm 2.8.45 noarch Fedora
php-symfony-options-resolver-2.8.45-1.fc29.noarch.rpm 2.8.45 noarch Fedora
php-symfony-options-resolver - - -

Requires

Name Value
php-reflection -
php-spl -
php-symfony-common = 2.8.51-1.fc29.remi

Provides

Name Value
php-composer(symfony/options-resolver) = 2.8.51
php-pear(pear.symfony.com/OptionsResolver) = 2.8.51
php-symfony-options-resolver = 2.8.51-1.fc29.remi
php-symfony-optionsresolver = 2.8.51
php-symfony2-OptionsResolver = 2.8.51

Obsoletes

Name Value
php-symfony-optionsresolver < 2.8.51
php-symfony2-OptionsResolver < 2.8.51

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-symfony-options-resolver-2.8.51-1.fc29.remi.noarch.rpm
Source Package php-symfony-2.8.51-1.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-symfony-options-resolver rpm package:
    # dnf --enablerepo=remi install php-symfony-options-resolver

Files

Path
/usr/share/doc/php-symfony-options-resolver/CHANGELOG.md
/usr/share/doc/php-symfony-options-resolver/README.md
/usr/share/doc/php-symfony-options-resolver/composer.json
/usr/share/licenses/php-symfony-options-resolver/LICENSE
/usr/share/php/Symfony/Component/OptionsResolver/Options.php
/usr/share/php/Symfony/Component/OptionsResolver/OptionsResolver.php
/usr/share/php/Symfony/Component/OptionsResolver/OptionsResolverInterface.php
/usr/share/php/Symfony/Component/OptionsResolver/autoload.php
/usr/share/php/Symfony/Component/OptionsResolver/autoloader.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/AccessException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/ExceptionInterface.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/InvalidArgumentException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/InvalidOptionsException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/MissingOptionsException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/NoSuchOptionException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/OptionDefinitionException.php
/usr/share/php/Symfony/Component/OptionsResolver/Exception/UndefinedOptionsException.php

Changelog

2019-04-18 - Remi Collet <remi@remirepo.net> - 2.8.51-1
- update to 2.8.51
2018-12-07 - Remi Collet <remi@remirepo.net> - 2.8.49-1
- update to 2.8.49
2018-11-27 - Remi Collet <remi@remirepo.net> - 2.8.48-1
- update to 2.8.48

See Also

Package Description
php-symfony-phpunit-bridge-2.8.51-1.fc29.remi.noarch.rpm Symfony PHPUnit Bridge
php-symfony-phpunit-bridge-2.8.51-2.fc29.remi.noarch.rpm Symfony PHPUnit Bridge
php-symfony-polyfill-1.11.0-1.fc29.remi.noarch.rpm Symfony polyfills backporting features to lower PHP versions
php-symfony-polyfill-1.12.0-1.fc29.remi.noarch.rpm Symfony polyfills backporting features to lower PHP versions
php-symfony-process-2.8.51-1.fc29.remi.noarch.rpm Symfony Process Component
php-symfony-process-2.8.51-2.fc29.remi.noarch.rpm Symfony Process Component
php-symfony-property-access-2.8.51-1.fc29.remi.noarch.rpm Symfony PropertyAccess Component
php-symfony-property-access-2.8.51-2.fc29.remi.noarch.rpm Symfony PropertyAccess Component
php-symfony-property-info-2.8.51-1.fc29.remi.noarch.rpm Symfony Property Info Component
php-symfony-property-info-2.8.51-2.fc29.remi.noarch.rpm Symfony Property Info Component
php-symfony-proxy-manager-bridge-2.8.51-1.fc29.remi.noarch.rpm Symfony ProxyManager Bridge
php-symfony-proxy-manager-bridge-2.8.51-2.fc29.remi.noarch.rpm Symfony ProxyManager Bridge
php-symfony-psr-http-message-bridge-1.1.2-1.fc29.remi.noarch.rpm Symfony PSR HTTP message bridge
php-symfony-routing-2.8.51-1.fc29.remi.noarch.rpm Symfony Routing Component
php-symfony-routing-2.8.51-2.fc29.remi.noarch.rpm Symfony Routing Component
Advertisement
Advertisement