php-doctrine-common-2.10.0-1.fc29.remi.noarch.rpm


Advertisement

Description

php-doctrine-common - Common library for Doctrine projects

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename php-doctrine-common-2.10.0-1.fc29.remi.noarch.rpm
Package name php-doctrine-common
Package version 2.10.0
Package release 1.fc29.remi
Package architecture noarch
Package type rpm
Category Development/Libraries
Homepage https://github.com/doctrine/common
License MIT
Maintainer -
Download size 28.86 KB
Installed size 76.31 KB
The Doctrine Common project is a library that provides extensions to core PHP
functionality.
Autoloader: /usr/share/php/Doctrine/Common/autoload.php

Alternatives

Package Version Architecture Repository
php-doctrine-common-2.11.0-1.fc29.remi.noarch.rpm 2.11.0 noarch Les RPM de Remi
php-doctrine-common-2.11.0-1.fc29.remi.noarch.rpm 2.11.0 noarch Les RPM de Remi
php-doctrine-common-2.10.0-1.fc29.remi.noarch.rpm 2.10.0 noarch Les RPM de Remi
php-doctrine-common-2.7.3-3.fc29.noarch.rpm 2.7.3 noarch Fedora
php-doctrine-common-2.7.3-3.fc29.noarch.rpm 2.7.3 noarch Fedora
php-doctrine-common - - -

Requires

Name Value
(php-composer(doctrine/annotations) >= 1.2.6 with php-composer(doctrine/annotations) < 2.0)
(php-composer(doctrine/cache) >= 1.4.1 with php-composer(doctrine/cache) < 2.0)
(php-composer(doctrine/collections) >= 1.3.0 with php-composer(doctrine/collections) < 2.0)
(php-composer(doctrine/event-manager) >= 1.0 with php-composer(doctrine/event-manager) < 2)
(php-composer(doctrine/inflector) >= 1.0.1 with php-composer(doctrine/inflector) < 2.0)
(php-composer(doctrine/lexer) >= 1.0.1 with php-composer(doctrine/lexer) < 2.0)
(php-composer(doctrine/persistence) >= 1.1 with php-composer(doctrine/persistence) < 2)
(php-composer(doctrine/reflection) >= 1.0 with php-composer(doctrine/reflection) < 2)
php(language) >= 7.1
php-composer(fedora/autoloader) -
php-pcre -
php-reflection -
php-spl -
php-tokenizer -

Provides

Name Value
php-composer(doctrine/common) = 2.10.0
php-doctrine-DoctrineCommon = 2.10.0
php-doctrine-common = 2.10.0-1.fc29.remi
php-pear(pear.doctrine-project.org/DoctrineCommon) = 2.10.0

Obsoletes

Name Value
php-doctrine-DoctrineCommon < 2.10.0

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-doctrine-common-2.10.0-1.fc29.remi.noarch.rpm
Source Package php-doctrine-common-2.10.0-1.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-doctrine-common rpm package:
    # dnf --enablerepo=remi install php-doctrine-common

Files

Path
/usr/share/doc/php-doctrine-common/README.md
/usr/share/doc/php-doctrine-common/UPGRADE_TO_2_1
/usr/share/doc/php-doctrine-common/UPGRADE_TO_2_2
/usr/share/doc/php-doctrine-common/composer.json
/usr/share/licenses/php-doctrine-common/LICENSE
/usr/share/php/Doctrine/Common/ClassLoader.php
/usr/share/php/Doctrine/Common/CommonException.php
/usr/share/php/Doctrine/Common/Comparable.php
/usr/share/php/Doctrine/Common/Lexer.php
/usr/share/php/Doctrine/Common/Version.php
/usr/share/php/Doctrine/Common/autoload.php
/usr/share/php/Doctrine/Common/Proxy/AbstractProxyFactory.php
/usr/share/php/Doctrine/Common/Proxy/Autoloader.php
/usr/share/php/Doctrine/Common/Proxy/Proxy.php
/usr/share/php/Doctrine/Common/Proxy/ProxyDefinition.php
/usr/share/php/Doctrine/Common/Proxy/ProxyGenerator.php
/usr/share/php/Doctrine/Common/Proxy/Exception/InvalidArgumentException.php
/usr/share/php/Doctrine/Common/Proxy/Exception/OutOfBoundsException.php
/usr/share/php/Doctrine/Common/Proxy/Exception/ProxyException.php
/usr/share/php/Doctrine/Common/Proxy/Exception/UnexpectedValueException.php
/usr/share/php/Doctrine/Common/Util/ClassUtils.php
/usr/share/php/Doctrine/Common/Util/Debug.php
/usr/share/php/Doctrine/Common/Util/Inflector.php

Changelog

2018-11-22 - Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- raise dependency on doctrine/persistence 1.1
2018-10-18 - Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- switch to phpunit6
- add dependency on doctrine/event-manager
- add dependency on doctrine/reflection
- add dependency on doctrine/persistence
2018-10-17 - Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1
- raise dependency on PHP 7.1

See Also

Package Description
php-doctrine-datafixtures-1.3.1-1.fc29.remi.noarch.rpm Data Fixtures for all Doctrine Object Managers
php-doctrine-datafixtures-1.3.2-1.fc29.remi.noarch.rpm Data Fixtures for all Doctrine Object Managers
php-doctrine-dbal-2.9.1-1.fc29.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-dbal-2.9.2-1.fc29.remi.noarch.rpm Doctrine Database Abstraction Layer (DBAL)
php-doctrine-doctrine-bundle-1.11.1-1.fc29.remi.noarch.rpm Symfony Bundle for Doctrine
php-doctrine-doctrine-bundle-1.11.2-1.fc29.remi.noarch.rpm Symfony Bundle for Doctrine
php-doctrine-doctrine-cache-bundle-1.3.4-1.fc29.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-doctrine-cache-bundle-1.3.5-1.fc29.remi.noarch.rpm Symfony2 Bundle for Doctrine Cache
php-doctrine-event-manager-1.0.0-1.fc29.remi.noarch.rpm Simple PHP event system
php-doctrine-event-manager-1.0.0-2.fc29.remi.noarch.rpm Simple PHP event system
php-doctrine-instantiator-1.2.0-1.fc29.remi.noarch.rpm Instantiate objects in PHP without invoking their constructors
php-doctrine-lexer-1.0.2-1.fc29.remi.noarch.rpm Base library for a lexer that can be used in top-down, recursive descent parsers
php-doctrine-lexer-1.1.0-1.fc29.remi.noarch.rpm Base library for a lexer that can be used in top-down, recursive descent parsers
php-doctrine-migrations-2.1.0-1.fc29.remi.noarch.rpm PHP Doctrine Migrations project
php-doctrine-migrations-2.1.1-1.fc29.remi.noarch.rpm PHP Doctrine Migrations project
Advertisement
Advertisement