php-pecl-amqp-1.9.4-6.fc29.remi.7.2.x86_64.rpm


Advertisement

Description

php-pecl-amqp - Communicate with any AMQP compliant server

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename php-pecl-amqp-1.9.4-6.fc29.remi.7.2.x86_64.rpm
Package name php-pecl-amqp
Package version 1.9.4
Package release 6.fc29.remi.7.2
Package architecture x86_64
Package type rpm
Homepage http://pecl.php.net/package/amqp
License PHP
Maintainer -
Download size 93.91 KB
Installed size 448.96 KB
This extension can communicate with any AMQP spec 0-9-1 compatible server,
such as RabbitMQ, OpenAMQP and Qpid, giving you the ability to create and
delete exchanges and queues, as well as publish to any exchange and consume
from any queue.
Package built for PHP 7.2.

Alternatives

Package Version Architecture Repository
php-pecl-amqp-1.9.4-6.fc29.remi.7.2.i686.rpm 1.9.4 i686 Les RPM de Remi
php-pecl-amqp-1.9.4-1.fc29.x86_64.rpm 1.9.4 x86_64 Fedora Updates
php-pecl-amqp-1.9.4-1.fc29.i686.rpm 1.9.4 i686 Fedora Updates
php-pecl-amqp-1.9.3-6.fc29.remi.7.2.x86_64.rpm 1.9.3 x86_64 Les RPM de Remi
php-pecl-amqp-1.9.3-6.fc29.remi.7.2.i686.rpm 1.9.3 i686 Les RPM de Remi
php-pecl-amqp-1.9.3-4.fc29.x86_64.rpm 1.9.3 x86_64 Fedora
php-pecl-amqp-1.9.3-4.fc29.i686.rpm 1.9.3 i686 Fedora
php-pecl-amqp - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
librabbitmq(x86-64) >= 0.9.0
librabbitmq.so.4()(64bit) -
php(api) = 20170718-64
php(zend-abi) = 20170718-64
rtld(GNU_HASH) -

Provides

Name Value
config(php-pecl-amqp) = 1.9.4-6.fc29.remi.7.2
php-amqp = 1.9.4
php-amqp(x86-64) = 1.9.4
php-pecl(amqp) = 1.9.4
php-pecl(amqp)(x86-64) = 1.9.4
php-pecl-amqp = 1.9.4-6.fc29.remi.7.2
php-pecl-amqp(x86-64) = 1.9.4-6.fc29.remi.7.2

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-pecl-amqp-1.9.4-6.fc29.remi.7.2.x86_64.rpm
Source Package php-pecl-amqp-1.9.4-6.fc29.remi.7.2.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-pecl-amqp rpm package:
    # dnf --enablerepo=remi install php-pecl-amqp

Files

Path
/etc/php-zts.d/40-amqp.ini
/etc/php.d/40-amqp.ini
/usr/lib/.build-id/
/usr/lib/.build-id/16/bf4ec267a449a83e806747783e6e5f8dd1f4ce
/usr/lib/.build-id/23/b5863a81e8a4eab788da75394906d05cbca946
/usr/lib64/php-zts/modules/amqp.so
/usr/lib64/php/modules/amqp.so
/usr/share/doc/pecl/amqp/CREDITS
/usr/share/doc/pecl/amqp/benchmark.php
/usr/share/doc/pecl/amqp/stubs/AMQP.php
/usr/share/doc/pecl/amqp/stubs/AMQPBasicProperties.php
/usr/share/doc/pecl/amqp/stubs/AMQPChannel.php
/usr/share/doc/pecl/amqp/stubs/AMQPChannelException.php
/usr/share/doc/pecl/amqp/stubs/AMQPConnection.php
/usr/share/doc/pecl/amqp/stubs/AMQPConnectionException.php
/usr/share/doc/pecl/amqp/stubs/AMQPDecimal.php
/usr/share/doc/pecl/amqp/stubs/AMQPEnvelope.php
/usr/share/doc/pecl/amqp/stubs/AMQPEnvelopeException.php
/usr/share/doc/pecl/amqp/stubs/AMQPException.php
/usr/share/doc/pecl/amqp/stubs/AMQPExchange.php
/usr/share/doc/pecl/amqp/stubs/AMQPExchangeException.php
/usr/share/doc/pecl/amqp/stubs/AMQPQueue.php
/usr/share/doc/pecl/amqp/stubs/AMQPQueueException.php
/usr/share/doc/pecl/amqp/stubs/AMQPTimestamp.php
/usr/share/doc/pecl/amqp/stubs/AMQPValueException.php
/usr/share/licenses/php-pecl-amqp/LICENSE
/var/lib/php/peclxml/php-pecl-amqp.xml

Changelog

2019-01-02 - Remi Collet <remi@remirepo.net> - 1.9.4-1
- update to 1.9.4
- drop patch merged upstream
2018-08-16 - Remi Collet <remi@remirepo.net> - 1.9.3-6
- rebuild for 7.3.0beta2 new ABI
2018-07-17 - Remi Collet <remi@remirepo.net> - 1.9.3-5
- rebuld for 7.3.0alpha4 new ABI

See Also

Package Description
php-pecl-apcu-5.1.16-1.fc29.remi.7.2.x86_64.rpm APC User Cache
php-pecl-apcu-5.1.17-1.fc29.remi.7.2.x86_64.rpm APC User Cache
php-pecl-apcu-bc-1.0.4-3.fc29.remi.7.2.x86_64.rpm APCu Backwards Compatibility Module
php-pecl-apcu-bc-1.0.5-1.fc29.remi.7.2.x86_64.rpm APCu Backwards Compatibility Module
php-pecl-apcu-devel-5.1.16-1.fc29.remi.7.2.x86_64.rpm APCu developer files (header)
php-pecl-apcu-devel-5.1.17-1.fc29.remi.7.2.x86_64.rpm APCu developer files (header)
php-pecl-apfd-1.0.1-12.fc29.remi.7.2.x86_64.rpm Always Populate Form Data
php-pecl-apm-2.1.3-2.fc29.remi.7.2.x86_64.rpm Alternative PHP Monitor
php-pecl-base58-0.1.3-1.fc29.remi.7.2.x86_64.rpm Encode and decode data with base58
php-pecl-base58-0.1.4-1.fc29.remi.7.2.x86_64.rpm Encode and decode data with base58
php-pecl-bitset-3.0.1-3.fc29.remi.7.2.x86_64.rpm BITSET library
php-pecl-cassandra-1.3.2-4.fc29.remi.7.2.x86_64.rpm DataStax PHP Driver for Apache Cassandra
php-pecl-cmark-1.1.0-3.fc29.remi.7.2.x86_64.rpm CommonMark extension
php-pecl-cmark-1.2.0-1.fc29.remi.7.2.x86_64.rpm CommonMark extension
php-pecl-couchbase2-2.6.0-1.fc29.remi.7.2.x86_64.rpm Couchbase Server PHP extension
Advertisement
Advertisement