php-phpunit-phploc-5.0.0-1.fc29.remi.noarch.rpm


Advertisement

Description

php-phpunit-phploc - A tool for quickly measuring the size of a PHP project

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename php-phpunit-phploc-5.0.0-1.fc29.remi.noarch.rpm
Package name php-phpunit-phploc
Package version 5.0.0
Package release 1.fc29.remi
Package architecture noarch
Package type rpm
Homepage https://github.com/sebastianbergmann/phploc
License BSD
Maintainer -
Download size 22.54 KB
Installed size 67.58 KB
phploc is a tool for quickly measuring the size of a PHP project.
The goal of phploc is not not to replace more sophisticated tools such as phpcs,
pdepend, or phpmd, but rather to provide an alternative to them when you just
need to get a quick understanding of a project's size.

Alternatives

Package Version Architecture Repository
php-phpunit-phploc-5.0.0-1.fc29.remi.noarch.rpm 5.0.0 noarch Les RPM de Remi
php-phpunit-phploc-4.0.1-4.fc29.remi.noarch.rpm 4.0.1 noarch Les RPM de Remi
php-phpunit-phploc-4.0.1-4.fc29.remi.noarch.rpm 4.0.1 noarch Les RPM de Remi
php-phpunit-phploc-4.0.1-3.fc29.noarch.rpm 4.0.1 noarch Fedora
php-phpunit-phploc-4.0.1-3.fc29.noarch.rpm 4.0.1 noarch Fedora
php-phpunit-phploc - - -

Requires

Name Value
(php-composer(sebastian/finder-facade) >= 1.1 with php-composer(sebastian/finder-facade) < 2)
(php-composer(sebastian/version) >= 2.0 with php-composer(sebastian/version) < 3)
(php-composer(symfony/console) >= 4.0 with php-composer(symfony/console) < 5)
/usr/bin/env -
php(language) >= 7.2
php-cli -
php-composer(fedora/autoloader) -
php-dom -
php-json -
php-spl -
php-tokenizer -

Provides

Name Value
php-composer(phploc/phploc) = 5.0.0
php-pear(pear.phpunit.de/phploc) = 5.0.0
php-phpunit-phploc = 5.0.0-1.fc29.remi
phploc = 5.0.0

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-phpunit-phploc-5.0.0-1.fc29.remi.noarch.rpm
Source Package php-phpunit-phploc-5.0.0-1.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-phpunit-phploc rpm package:
    # dnf --enablerepo=remi install php-phpunit-phploc

Files

Path
/usr/bin/phploc
/usr/share/doc/php-phpunit-phploc/README.md
/usr/share/doc/php-phpunit-phploc/composer.json
/usr/share/licenses/php-phpunit-phploc/LICENSE
/usr/share/php/SebastianBergmann/PHPLOC/Analyser.php
/usr/share/php/SebastianBergmann/PHPLOC/Collector.php
/usr/share/php/SebastianBergmann/PHPLOC/Publisher.php
/usr/share/php/SebastianBergmann/PHPLOC/autoload.php
/usr/share/php/SebastianBergmann/PHPLOC/CLI/Application.php
/usr/share/php/SebastianBergmann/PHPLOC/CLI/Command.php
/usr/share/php/SebastianBergmann/PHPLOC/Exception/Exception.php
/usr/share/php/SebastianBergmann/PHPLOC/Exception/RuntimeException.php
/usr/share/php/SebastianBergmann/PHPLOC/Log/Csv.php
/usr/share/php/SebastianBergmann/PHPLOC/Log/Json.php
/usr/share/php/SebastianBergmann/PHPLOC/Log/Text.php
/usr/share/php/SebastianBergmann/PHPLOC/Log/Xml.php

Changelog

2019-03-17 - Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- raise dependency on PHP 7.2
- add dependency on php-json
- only allow Symfony 4
2018-10-15 - Remi Collet <remi@remirepo.net> - 4.0.1-4
- add patch for PHP 7.3
2018-02-06 - Remi Collet <remi@remirepo.net> - 4.0.1-2
- use range dependencies on F27+
- undefine __brp_mangle_shebangs

See Also

Package Description
php-phpunit-selenium-7.0.0-1.fc29.remi.noarch.rpm Selenium RC integration for PHPUnit
php-phpunitgoodpractices-polyfill-1.1.0-5.fc29.remi.noarch.rpm Lacking future-compat polyfills for PHPUnit
php-phpunitgoodpractices-polyfill-1.2.0-1.fc29.remi.noarch.rpm Lacking future-compat polyfills for PHPUnit
php-pinba-1.1.1-4.fc29.remi.7.2.x86_64.rpm Client extension for Pinba statistics server
php-pragmarx-google2fa-3.0.3-1.fc29.remi.noarch.rpm Google Two-Factor Authentication for PHP Package
php-pragmarx-google2fa-qrcode-1.0.3-1.fc29.remi.noarch.rpm QR Code package for Google2FA
php-pragmarx-google2fa5-5.0.0-1.fc29.remi.noarch.rpm Google Two-Factor Authentication for PHP Package
php-process-7.2.22-1.fc29.remi.x86_64.rpm Modules for PHP script using system process interfaces
php-process-7.2.23-1.fc29.remi.x86_64.rpm Modules for PHP script using system process interfaces
php-pspell-7.2.22-1.fc29.remi.x86_64.rpm A module for PHP applications for using pspell interfaces
php-pspell-7.2.23-1.fc29.remi.x86_64.rpm A module for PHP applications for using pspell interfaces
php-psr-http-factory-1.0.0-1.fc29.remi.noarch.rpm Common interfaces for PSR-7 HTTP message factories
php-psr-http-factory-1.0.1-1.fc29.remi.noarch.rpm Common interfaces for PSR-7 HTTP message factories
php-punic-1.6.5-7.fc29.remi.noarch.rpm PHP-Unicode CLDR
php-react-cache-0.5.0-1.fc29.remi.noarch.rpm Async caching
Advertisement
Advertisement