php-pragmarx-google2fa-3.0.3-1.fc29.remi.noarch.rpm


Advertisement

Description

php-pragmarx-google2fa - Google Two-Factor Authentication for PHP Package

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename php-pragmarx-google2fa-3.0.3-1.fc29.remi.noarch.rpm
Package name php-pragmarx-google2fa
Package version 3.0.3
Package release 1.fc29.remi
Package architecture noarch
Package type rpm
Homepage https://github.com/antonioribeiro/google2fa
License MIT
Maintainer -
Download size 19.84 KB
Installed size 31.77 KB
Google2FA is a PHP implementation of the Google Two-Factor Authentication
Module, supporting the HMAC-Based One-time Password (HOTP) algorithm
specified in RFC 4226 and the Time-based One-time Password (TOTP) algorithm
specified in RFC 6238.
Autoloader: /usr/share/php/PragmaRX/Google2FA/autoload.php

Alternatives

Package Version Architecture Repository
php-pragmarx-google2fa-3.0.3-1.fc29.remi.noarch.rpm 3.0.3 noarch Les RPM de Remi
php-pragmarx-google2fa-3.0.3-1.fc29.noarch.rpm 3.0.3 noarch Fedora
php-pragmarx-google2fa-3.0.3-1.fc29.noarch.rpm 3.0.3 noarch Fedora Updates Testing
php-pragmarx-google2fa-3.0.3-1.fc29.noarch.rpm 3.0.3 noarch Fedora Updates Testing
php-pragmarx-google2fa-3.0.3-1.fc29.noarch.rpm 3.0.3 noarch Fedora
php-pragmarx-google2fa - - -

Requires

Name Value
(php-composer(paragonie/constant_time_encoding) >= 1.0 with php-composer(paragonie/constant_time_encoding) < 3)
(php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
php(language) >= 5.6
php-composer(fedora/autoloader) -
php-hash -
php-pcre -

Provides

Name Value
php-composer(pragmarx/google2fa) = 3.0.3
php-pragmarx-google2fa = 3.0.3-1.fc29.remi

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-pragmarx-google2fa-3.0.3-1.fc29.remi.noarch.rpm
Source Package php-pragmarx-google2fa-3.0.3-1.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-pragmarx-google2fa rpm package:
    # dnf --enablerepo=remi install php-pragmarx-google2fa

Files

Path
/usr/share/doc/php-pragmarx-google2fa/README.md
/usr/share/doc/php-pragmarx-google2fa/changelog.md
/usr/share/doc/php-pragmarx-google2fa/composer.json
/usr/share/licenses/php-pragmarx-google2fa/LICENSE.md
/usr/share/licenses/php-pragmarx-google2fa/RELICENSED.md
/usr/share/php/PragmaRX/
/usr/share/php/PragmaRX/Google2FA/Google2FA.php
/usr/share/php/PragmaRX/Google2FA/autoload.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/IncompatibleWithGoogleAuthenticatorException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/InsecureCallException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/InvalidCharactersException.php
/usr/share/php/PragmaRX/Google2FA/Exceptions/SecretKeyTooShortException.php
/usr/share/php/PragmaRX/Google2FA/Support/Base32.php
/usr/share/php/PragmaRX/Google2FA/Support/Constants.php
/usr/share/php/PragmaRX/Google2FA/Support/QRCode.php
/usr/share/php/PragmaRX/Google2FA/Support/Url.php

Changelog

2018-08-29 - Remi Collet <remi@remirepo.net> - 3.0.3-1
- update to 3.0.3 (no change)
2018-08-20 - Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2 (no change)
2018-05-02 - Remi Collet <remi@remirepo.net> - 3.0.1-2
- allow paragonie/constant_time_encoding v2

See Also

Package Description
php-pragmarx-google2fa-qrcode-1.0.3-1.fc29.remi.noarch.rpm QR Code package for Google2FA
php-pragmarx-google2fa5-5.0.0-1.fc29.remi.noarch.rpm Google Two-Factor Authentication for PHP Package
php-process-7.2.22-1.fc29.remi.x86_64.rpm Modules for PHP script using system process interfaces
php-process-7.2.23-1.fc29.remi.x86_64.rpm Modules for PHP script using system process interfaces
php-pspell-7.2.22-1.fc29.remi.x86_64.rpm A module for PHP applications for using pspell interfaces
php-pspell-7.2.23-1.fc29.remi.x86_64.rpm A module for PHP applications for using pspell interfaces
php-psr-http-factory-1.0.0-1.fc29.remi.noarch.rpm Common interfaces for PSR-7 HTTP message factories
php-psr-http-factory-1.0.1-1.fc29.remi.noarch.rpm Common interfaces for PSR-7 HTTP message factories
php-punic-1.6.5-7.fc29.remi.noarch.rpm PHP-Unicode CLDR
php-react-cache-0.5.0-1.fc29.remi.noarch.rpm Async caching
php-react-child-process-0.5.2-1.fc29.remi.noarch.rpm Library for executing child processes
php-react-dns-0.4.14-1.fc29.remi.noarch.rpm Async DNS resolver
php-react-event-loop-0.5.2-1.fc29.remi.noarch.rpm Event loop abstraction layer that libraries can use for evented I/O
php-react-http-0.8.3-1.fc29.remi.noarch.rpm Library for building an evented http server
php-react-http-client-0.5.9-1.fc29.remi.noarch.rpm Asynchronous HTTP client library
Advertisement
Advertisement