php71-php-pecl-oci8-2.2.0-2.fc29.remi.x86_64.rpm


Advertisement

Description

php71-php-pecl-oci8 - Extension for Oracle Database

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename php71-php-pecl-oci8-2.2.0-2.fc29.remi.x86_64.rpm
Package name php71-php-pecl-oci8
Package version 2.2.0
Package release 2.fc29.remi
Package architecture x86_64
Package type rpm
Homepage http://pecl.php.net/package/oci8
License PHP
Maintainer -
Download size 86.34 KB
Installed size 281.76 KB
Use the OCI8 extension to access Oracle Database.
The extension is linked with Oracle client libraries 19.3
(Oracle Instant Client).  For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
You must install libclntsh.so.19.1 to use this package, provided
in the database installation, or in the free Oracle Instant Client
available from Oracle.
Notice:
- php71-php-oci8 provides oci8 and pdo_oci extensions from php sources.
- php71-php-pecl-oci8 only provides oci8 extension.
Documentation is at http://php.net/oci8
Package built for PHP 7.1 as Software Collection (php71 by remi).

Alternatives

Package Version Architecture Repository
php71-php-pecl-oci8-2.2.0-1.fc29.remi.x86_64.rpm 2.2.0 x86_64 Les RPM de Remi
php71-php-pecl-oci8 - - -

Requires

Name Value
php71-php(api) = 20160303-64
php71-php(zend-abi) = 20160303-64

Provides

Name Value
config(php71-php-pecl-oci8) = 2.2.0-2.fc29.remi
php71-php-oci8 = 2.2.0
php71-php-oci8(x86-64) = 2.2.0
php71-php-pecl(oci8) = 2.2.0
php71-php-pecl(oci8)(x86-64) = 2.2.0
php71-php-pecl-oci8 = 2.2.0-2.fc29.remi
php71-php-pecl-oci8(x86-64) = 2.2.0-2.fc29.remi
scl-package(php71) -

Conflicts

Name Value
php71-php-oci8 < 2.2.0

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php71-php-pecl-oci8-2.2.0-2.fc29.remi.x86_64.rpm
Source Package php71-php-pecl-oci8-2.2.0-2.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php71-php-pecl-oci8 rpm package:
    # dnf --enablerepo=remi install php71-php-pecl-oci8

Files

Path
/etc/opt/remi/php71/php.d/40-oci8.ini
/opt/remi/php71/root/usr/lib64/php/modules/oci8.so
/opt/remi/php71/root/usr/share/doc/pecl/oci8/CREDITS
/opt/remi/php71/root/usr/share/doc/pecl/oci8/README
/opt/remi/php71/root/usr/share/licenses/php71-php-pecl-oci8/LICENSE
/var/opt/remi/php71/lib/php/peclxml/php71-php-pecl-oci8.xml

Changelog

2019-08-26 - Remi Collet <remi@remirepo.net> - 2.2.0-2
- use oracle client library version 19.3
2018-12-10 - Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0
- raise dependency on PHP 7.0
- switch to oracle client library 18.3

See Also

Package Description
php71-php-pecl-opencensus-0.2.2-3.fc29.remi.x86_64.rpm A stats collection and distributed tracing framework
php71-php-pecl-parle-0.8.1-4.fc29.remi.x86_64.rpm Parsing and lexing
php71-php-pecl-pcov-1.0.5-1.fc29.remi.x86_64.rpm Code coverage driver
php71-php-pecl-pcov-1.0.6-1.fc29.remi.x86_64.rpm Code coverage driver
php71-php-pecl-pcs-1.3.3-3.fc29.remi.x86_64.rpm PHP Code Service
php71-php-pecl-pcs-devel-1.3.3-3.fc29.remi.x86_64.rpm PHP Code Service (header)
php71-php-pecl-pdflib-4.1.2-3.fc29.remi.x86_64.rpm Package for generating PDF files
php71-php-pecl-pdflib-4.1.3-1.fc29.remi.x86_64.rpm Package for generating PDF files
php71-php-pecl-pq-2.1.4-3.fc29.remi.x86_64.rpm PostgreSQL client library (libpq) binding
php71-php-pecl-pq-2.1.5-1.fc29.remi.x86_64.rpm PostgreSQL client library (libpq) binding
php71-php-pecl-propro-2.1.0-3.fc29.remi.x86_64.rpm Property proxy
php71-php-pecl-propro-devel-2.1.0-3.fc29.remi.x86_64.rpm php71-php-pecl-propro developer files (header)
php71-php-pecl-protobuf-3.10.0-1.fc29.remi.x86_64.rpm Mechanism for serializing structured data
php71-php-pecl-protobuf-3.9.2-1.fc29.remi.x86_64.rpm Mechanism for serializing structured data
php71-php-pecl-psr-0.6.1-1.fc29.remi.x86_64.rpm PSR interfaces
Advertisement
Advertisement