phpcpd-4.1.0-1.fc29.remi.noarch.rpm


Advertisement

Description

phpcpd - Copy/Paste Detector (CPD) for PHP code

Property Value
Distribution Fedora 29
Repository Les RPM de Remi x86_64
Package filename phpcpd-4.1.0-1.fc29.remi.noarch.rpm
Package name phpcpd
Package version 4.1.0
Package release 1.fc29.remi
Package architecture noarch
Package type rpm
Homepage https://github.com/sebastianbergmann/phpcpd
License BSD
Maintainer -
Download size 19.53 KB
Installed size 36.29 KB
phpcpd is a Copy/Paste Detector (CPD) for PHP code.
The goal of phpcpd is not not to replace more sophisticated tools such as phpcs,
pdepend, or phpmd, but rather to provide an alternative to them when you just
need to get a quick overview of duplicated code in a project.

Alternatives

Package Version Architecture Repository
phpcpd-4.1.0-1.fc29.remi.noarch.rpm 4.1.0 noarch Les RPM de Remi
phpcpd-4.1.0-1.fc29.noarch.rpm 4.1.0 noarch Fedora
phpcpd-4.1.0-1.fc29.noarch.rpm 4.1.0 noarch Fedora Updates Testing
phpcpd-4.1.0-1.fc29.noarch.rpm 4.1.0 noarch Fedora Updates Testing
phpcpd-4.1.0-1.fc29.noarch.rpm 4.1.0 noarch Fedora
phpcpd - - -

Requires

Name Value
(php-composer(phpunit/php-timer) >= 2.0 with php-composer(phpunit/php-timer) < 3)
(php-composer(sebastian/finder-facade) >= 1.1 with php-composer(sebastian/finder-facade) < 2)
(php-composer(sebastian/version) >= 1.0 with php-composer(sebastian/version) < 3)
(php-composer(symfony/console) >= 2.7 with php-composer(symfony/console) < 5)
/usr/bin/env -
php(language) >= 7.1
php-cli -
php-dom -
php-mbstring -
php-pcre -
php-spl -
php-tokenizer -
php-xml -

Provides

Name Value
php-composer(sebastian/phpcpd) = 4.1.0
php-phpunit-phpcpd = 4.1.0
phpcpd = 4.1.0-1.fc29.remi

Obsoletes

Name Value
php-phpunit-phpcpd < 4

Download

Type URL
Mirror rpms.remirepo.net
Binary Package phpcpd-4.1.0-1.fc29.remi.noarch.rpm
Source Package phpcpd-4.1.0-1.fc29.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/fedora/29/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install phpcpd rpm package:
    # dnf --enablerepo=remi install phpcpd

Files

Path
/usr/bin/phpcpd
/usr/share/doc/phpcpd/README.md
/usr/share/doc/phpcpd/composer.json
/usr/share/licenses/phpcpd/LICENSE
/usr/share/php/SebastianBergmann/PHPCPD/CodeClone.php
/usr/share/php/SebastianBergmann/PHPCPD/CodeCloneFile.php
/usr/share/php/SebastianBergmann/PHPCPD/CodeCloneMap.php
/usr/share/php/SebastianBergmann/PHPCPD/CodeCloneMapIterator.php
/usr/share/php/SebastianBergmann/PHPCPD/autoload.php
/usr/share/php/SebastianBergmann/PHPCPD/CLI/Application.php
/usr/share/php/SebastianBergmann/PHPCPD/CLI/Command.php
/usr/share/php/SebastianBergmann/PHPCPD/Detector/Detector.php
/usr/share/php/SebastianBergmann/PHPCPD/Detector/Strategy/AbstractStrategy.php
/usr/share/php/SebastianBergmann/PHPCPD/Detector/Strategy/DefaultStrategy.php
/usr/share/php/SebastianBergmann/PHPCPD/Log/AbstractXmlLogger.php
/usr/share/php/SebastianBergmann/PHPCPD/Log/PMD.php
/usr/share/php/SebastianBergmann/PHPCPD/Log/Text.php

Changelog

2018-09-18 - Remi Collet <remi@remirepo.net> - 4.1.0-1
- update to 4.1.0
2018-02-06 - Remi Collet <remi@remirepo.net> - 4.0.0-1
- Update to 4.0.0
- rename to phpcpd (and obsolete php-phpunit-phpcpd)
- raise dependency on PHP 7.1
- raise dependency on phpunit/php-timer 2.0
- use phpunit7 for test suite
2018-02-06 - Remi Collet <remi@remirepo.net> - 3.0.1-2
- use range dependencies on F27+

See Also

Package Description
phpdoc-2.9.0-7.fc29.remi.noarch.rpm Documentation generator for PHP
phpunit6-6.5.14-1.fc29.remi.noarch.rpm The PHP Unit Testing framework
phpunit6-6.5.14-2.fc29.remi.noarch.rpm The PHP Unit Testing framework version 6
phpunit7-7.5.15-1.fc29.remi.noarch.rpm The PHP Unit Testing framework version 7
phpunit7-7.5.16-1.fc29.remi.noarch.rpm The PHP Unit Testing framework version 7
phpunit8-8.4.0-1.fc29.remi.noarch.rpm The PHP Unit Testing framework version 8
phpunit8-8.4.1-1.fc29.remi.noarch.rpm The PHP Unit Testing framework version 8
python2-vips-8.7.3-1.fc29.remi.x86_64.rpm Python 2 support for vips
python2-vips-8.7.4-1.fc29.remi.x86_64.rpm Python 2 support for vips
python3-vips-8.7.3-1.fc29.remi.x86_64.rpm Python 3 support for vips
python3-vips-8.7.4-1.fc29.remi.x86_64.rpm Python 3 support for vips
qelectrotech-0.61-1.fc29.remi.x86_64.rpm Éditeur de schémas électriques
qelectrotech-0.70-1.fc29.remi.x86_64.rpm Éditeur de schémas électriques
qelectrotech-symbols-0.61-1.fc29.remi.noarch.rpm Collection d'éléments pour QElectroTech
qelectrotech-symbols-0.70-1.fc29.remi.noarch.rpm Collection d'éléments pour QElectroTech
Advertisement
Advertisement