cocoalib-0.99601-1.fc30.i686.rpm


Advertisement

Description

cocoalib - C++ library for computations in commutative algebra

Property Value
Distribution Fedora 30
Repository Fedora Updates Testing i386
Package filename cocoalib-0.99601-1.fc30.i686.rpm
Package name cocoalib
Package version 0.99601
Package release 1.fc30
Package architecture i686
Package type rpm
Homepage http://cocoa.dima.unige.it/cocoalib/
License GPLv3+
Maintainer -
Download size 1.52 MB
Installed size 5.45 MB
The CoCoA C++ library offers functions to perform calculations in
Computational Commutative Algebra, and some other related areas.  The
library is designed to be pleasant to use while offering good run-time
performance.

Alternatives

Package Version Architecture Repository
cocoalib-0.99601-1.fc30.i686.rpm 0.99601 i686 Fedora
cocoalib-0.99601-1.fc30.x86_64.rpm 0.99601 x86_64 Fedora
cocoalib-0.99601-1.fc30.i686.rpm 0.99601 i686 Fedora
cocoalib-0.99601-1.fc30.x86_64.rpm 0.99601 x86_64 Fedora Updates Testing
cocoalib-0.99601-1.fc30.i686.rpm 0.99601 i686 Fedora Updates Testing
cocoalib - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libfrobby.so.0 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.4) -
libgfan.so.0 -
libgmp.so.10 -
libgsl.so.23 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.29) -
libopenblas.so.0 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.5) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rtld(GNU_HASH) -

Provides

Name Value
cocoalib = 0.99601-1.fc30
cocoalib(x86-32) = 0.99601-1.fc30
libcocoa.so.0 -

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package cocoalib-0.99601-1.fc30.i686.rpm
Source Package cocoalib-0.99601-1.fc30.src.rpm

Install Howto

Install cocoalib rpm package:

# dnf --enablerepo=updates-testing install cocoalib

Files

Path
/usr/lib/libcocoa.so.0
/usr/lib/libcocoa.so.0.0.0
/usr/lib/.build-id/
/usr/lib/.build-id/8a/09f05e247af89c944bdbbbb3e1c25956c717f0
/usr/share/doc/cocoalib/README
/usr/share/licenses/cocoalib/COPYING-GPLv3

Changelog

2019-03-12 - Jerry James <loganjerry@gmail.com> - 0.99601-1
- New upstream version
2019-01-31 - Fedora Release Engineering <releng@fedoraproject.org> - 0.99600-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2018-10-13 - Jerry James <loganjerry@gmail.com> - 0.99600-2
- Build with openblas instead of atlas (bz 1618942)
2018-08-10 - Jerry James <loganjerry@gmail.com> - 0.99600-1
- New upstream version
2018-07-12 - Fedora Release Engineering <releng@fedoraproject.org> - 0.99564-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-16 - Jerry James <loganjerry@gmail.com> - 0.99564-1
- New upstream version
- Drop upstreamed -return patch
- Add -include and -bigrat patches to fix FTBFS
2018-06-11 - Jerry James <loganjerry@gmail.com> - 0.99563-2
- Make -doc subpackage noarch
2018-06-09 - Jerry James <loganjerry@gmail.com> - 0.99563-1
- Initial RPM

See Also

Package Description
cocoalib-devel-0.99601-1.fc30.i686.rpm Headers and library links for cocoalib
cocoalib-doc-0.99601-1.fc30.noarch.rpm Documentation for cocoalib
colord-1.4.4-1.fc30.i686.rpm Color daemon
colord-devel-1.4.4-1.fc30.i686.rpm Development package for colord
colord-devel-docs-1.4.4-1.fc30.noarch.rpm Developer documentation package for colord
colord-extra-profiles-1.4.4-1.fc30.noarch.rpm More color profiles for color management that are less commonly used
colord-libs-1.4.4-1.fc30.i686.rpm Color daemon library
colord-tests-1.4.4-1.fc30.i686.rpm Data files for installed tests
compat-golang-github-coreos-bbolt-devel-1.3.2-2.fc30.noarch.rpm An embedded key/value database for Go
compat-golang-github-coreos-etcd-devel-3.3.12-1.20190314gite1ca3b4.fc30.noarch.rpm etcd golang devel libraries
compat-golang-gopkg-fsnotify-1-devel-1.4.7-5.fc30.noarch.rpm Cross-platform file system notifications for Go
compat-libpthread-nonshared-2.29-9.fc30.i686.rpm Compatibility support for linking against libpthread_nonshared.a
compat-lua-cqueues-20171014-4.fc30.i686.rpm Stackable Continuation Queues for the Lua Programming Language 5.1
compat-lua-lpeg-1.0.1-9.fc30.i686.rpm Parsing Expression Grammars for Lua 5.1
compat-wxGTK3-gtk2-3.0.4-8.fc30.i686.rpm GTK port of the wxWidgets GUI library
Advertisement
Advertisement