libvirt-daemon-driver-interface-5.1.0-9.fc30.x86_64.rpm


Advertisement

Description

libvirt-daemon-driver-interface - Interface driver plugin for the libvirtd daemon

Property Value
Distribution Fedora 30
Repository Fedora Updates x86_64
Package filename libvirt-daemon-driver-interface-5.1.0-9.fc30.x86_64.rpm
Package name libvirt-daemon-driver-interface
Package version 5.1.0
Package release 9.fc30
Package architecture x86_64
Package type rpm
Homepage https://libvirt.org/
License LGPLv2+
Maintainer -
Download size 85.16 KB
Installed size 372.21 KB
The interface driver plugin for the libvirtd daemon, providing
an implementation of the network interface APIs using the
netcf library

Alternatives

Package Version Architecture Repository
libvirt-daemon-driver-interface-5.1.0-9.fc30.i686.rpm 5.1.0 i686 Fedora Updates
libvirt-daemon-driver-interface-5.1.0-4.fc30.i686.rpm 5.1.0 i686 Fedora
libvirt-daemon-driver-interface-5.1.0-4.fc30.x86_64.rpm 5.1.0 x86_64 Fedora
libvirt-daemon-driver-interface - - -

Requires

Name Value
libacl.so.1()(64bit) -
libaudit.so.1()(64bit) -
libavahi-client.so.3()(64bit) -
libavahi-common.so.3()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcap-ng.so.0()(64bit) -
libcurl.so.4()(64bit) -
libdbus-1.so.3()(64bit) -
libdevmapper.so.1.02()(64bit) -
libdl.so.2()(64bit) -
libgnutls.so.30()(64bit) -
libnetcf.so.1()(64bit) -
libnetcf.so.1(NETCF_1.0.0)(64bit) -
libnetcf.so.1(NETCF_1.2.0)(64bit) -
libnetcf.so.1(NETCF_1.3.0)(64bit) -
libnetcf.so.1(NETCF_1.4.0)(64bit) -
libnl-3.so.200()(64bit) -
libnl-route-3.so.200()(64bit) -
libnuma.so.1()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libsasl2.so.3()(64bit) -
libselinux.so.1()(64bit) -
libssh.so.4()(64bit) -
libssh2.so.1()(64bit) -
libtirpc.so.3()(64bit) -
libudev.so.1()(64bit) -
libudev.so.1(LIBUDEV_183)(64bit) -
libutil.so.1()(64bit) -
libvirt-daemon = 5.1.0-9.fc30
libvirt-libs = 5.1.0-9.fc30
libvirt.so.0()(64bit) -
libvirt.so.0(LIBVIRT_0.6.1)(64bit) -
libvirt.so.0(LIBVIRT_PRIVATE_5.1.0)(64bit) -
libwsman.so.1()(64bit) -
libwsman_client.so.4()(64bit) -
libwsman_curl_client_transport.so.1()(64bit) -
libxml2.so.2()(64bit) -
libyajl.so.2()(64bit) -
netcf-libs >= 0.2.2
rtld(GNU_HASH) -

Provides

Name Value
libvirt-daemon-driver-interface = 5.1.0-9.fc30
libvirt-daemon-driver-interface(x86-64) = 5.1.0-9.fc30
libvirt_driver_interface.so()(64bit) -

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package libvirt-daemon-driver-interface-5.1.0-9.fc30.x86_64.rpm
Source Package libvirt-5.1.0-9.fc30.src.rpm

Install Howto

Install libvirt-daemon-driver-interface rpm package:

# dnf install libvirt-daemon-driver-interface

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/86/66b53b9a39cd8f3c880b6bdc38b4be6099733a
/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so

Changelog

2019-06-20 - Cole Robinson <crobinso@redhat.com> - 5.1.0-9
- CVE-2019-10161: arbitrary file read/exec via virDomainSaveImageGetXMLDesc
API (bz #1722463, bz #1720115)
- CVE-2019-10166: virDomainManagedSaveDefineXML API exposed to readonly
clients (bz #1722462, bz #1720114)
- CVE-2019-10167: arbitrary command execution via
virConnectGetDomainCapabilities API (bz #1722464, bz #1720117)
- CVE-2019-10168: arbitrary command execution via
virConnectBaselineHypervisorCPU and virConnectCompareHypervisorCPU APIs (bz
- CVE-2019-3886: virsh domhostname command discloses guest hostname in
readonly mode [fedora-rawhide
- Cannot start VM with a CBR 2.0 TPM device (bz #1712556)
- libvirtd does not update VM .xml configurations after virsh
snapshot/blockcommit (bz #1722348)
2019-05-31 - Adam Williamson <awilliam@redhat.com> - 5.1.0-8
- Fix scriptlet error when built without firewalld zone support
2019-05-29 - Adam Williamson <awilliam@redhat.com> - 5.1.0-7
- Pass --without-firewalld-zone to configure
- Resolves: rhbz #1699051
2019-05-21 - Daniel P. Berrangé <berrange@redhat.com> - 5.1.0-6
- Fix systemd socket permissions
- Resolves: rhbz #1712498 (CVE-2019-10132)
2019-05-14 - Daniel P. Berrangé <berrange@redhat.com> - 5.1.0-5
- Define md-clear CPUID bit
- Resolves: rhbz #1709977 (CVE-2018-12126), rhbz #1709979 (CVE-2018-12127),
rhbz #1709997 (CVE-2018-12130), rhbz #1709984 (CVE-2019-11091)
2019-04-02 - Cole Robinson <crobinso@redhat.com> - 5.1.0-4
- Mouse cursor doubled on QEMU VNC on ppc64le (bz #1565253)
- Fix VM startup with cgroupv2 (bz #1688736)
2019-03-20 - Daniel P. Berrangé <berrange@redhat.com> - 5.1.0-3
- Fix upgrades for rbd on i686 (rhbz #1688121)
- Add missing xfsprogs-devel dep
- Fix use of deprecated RBD features
- Avoid using firewalld if unprivileged
- Don't require ipv6 firewall support at startup (rhbz #1688968)
2019-03-06 - Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5.1.0-2
- Remove obsolete scriptlets
2019-03-04 - Daniel P. Berrangé <berrange@redhat.com> - 5.1.0-1
- Update to 5.1.0 release
2019-02-17 - Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5.0.0-3
- Rebuild for readline 8.0

See Also

Package Description
libvirt-daemon-driver-libxl-5.1.0-9.fc30.x86_64.rpm Libxl driver plugin for the libvirtd daemon
libvirt-daemon-driver-lxc-5.1.0-9.fc30.x86_64.rpm LXC driver plugin for the libvirtd daemon
libvirt-daemon-driver-network-5.1.0-9.fc30.x86_64.rpm Network driver plugin for the libvirtd daemon
libvirt-daemon-driver-nodedev-5.1.0-9.fc30.x86_64.rpm Nodedev driver plugin for the libvirtd daemon
libvirt-daemon-driver-nwfilter-5.1.0-9.fc30.x86_64.rpm Nwfilter driver plugin for the libvirtd daemon
libvirt-daemon-driver-qemu-5.1.0-9.fc30.x86_64.rpm QEMU driver plugin for the libvirtd daemon
libvirt-daemon-driver-secret-5.1.0-9.fc30.x86_64.rpm Secret driver plugin for the libvirtd daemon
libvirt-daemon-driver-storage-5.1.0-9.fc30.x86_64.rpm Storage driver plugin including all backends for the libvirtd daemon
libvirt-daemon-driver-storage-core-5.1.0-9.fc30.x86_64.rpm Storage driver plugin including base backends for the libvirtd daemon
libvirt-daemon-driver-storage-disk-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for disk
libvirt-daemon-driver-storage-gluster-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for gluster
libvirt-daemon-driver-storage-iscsi-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for iscsi
libvirt-daemon-driver-storage-iscsi-direct-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for iscsi-direct
libvirt-daemon-driver-storage-logical-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for lvm volumes
libvirt-daemon-driver-storage-mpath-5.1.0-9.fc30.x86_64.rpm Storage driver plugin for multipath volumes
Advertisement
Advertisement