python3-rpkg-1.57-6.fc30.noarch.rpm


Advertisement

Description

python3-rpkg - Python library for interacting with rpm+git

Property Value
Distribution Fedora 30
Repository Fedora x86_64
Package filename python3-rpkg-1.57-6.fc30.noarch.rpm
Package name python3-rpkg
Package version 1.57
Package release 6.fc30
Package architecture noarch
Package type rpm
Homepage https://pagure.io/rpkg
License GPLv2+ and LGPLv2
Maintainer -
Download size 153.86 KB
Installed size 578.63 KB
A python library for managing RPM package sources in a git repository.

Alternatives

Package Version Architecture Repository
python3-rpkg-1.59-1.fc30.noarch.rpm 1.59 noarch Fedora Updates
python3-rpkg-1.59-1.fc30.noarch.rpm 1.59 noarch Fedora Updates
python3-rpkg-1.57-6.fc30.noarch.rpm 1.57 noarch Fedora
python3-rpkg - - -

Requires

Name Value
libmodulemd -
mock -
python(abi) = 3.7
python3-GitPython >= 0.2.0
python3-PyYAML -
python3-cccolutils -
python3-gobject-base -
python3-koji >= 1.15
python3-pycurl -
python3-rpm -
python3-six >= 1.9.0
python3.7dist(cccolutils) >= 1.4
python3.7dist(gitpython) -
python3.7dist(pycurl) >= 7.19
python3.7dist(pygobject) -
python3.7dist(pyyaml) -
python3.7dist(requests) -
python3.7dist(six) >= 1.9.0
redhat-rpm-config -
rpkg-common = 1.57-6.fc30
rpm-build -
rpmlint -

Provides

Name Value
python3-rpkg = 1.57-6.fc30
python3.7dist(rpkg) = 1.57
python3dist(rpkg) = 1.57

Conflicts

Name Value
fedpkg < 1.26

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package python3-rpkg-1.57-6.fc30.noarch.rpm
Source Package rpkg-1.57-6.fc30.src.rpm

Install Howto

Install python3-rpkg rpm package:

# dnf install python3-rpkg

Files

Path
/usr/lib/python3.7/site-packages/pyrpkg/__init__.py
/usr/lib/python3.7/site-packages/pyrpkg/cli.py
/usr/lib/python3.7/site-packages/pyrpkg/errors.py
/usr/lib/python3.7/site-packages/pyrpkg/gitignore.py
/usr/lib/python3.7/site-packages/pyrpkg/lookaside.py
/usr/lib/python3.7/site-packages/pyrpkg/man_gen.py
/usr/lib/python3.7/site-packages/pyrpkg/sources.py
/usr/lib/python3.7/site-packages/pyrpkg/utils.py
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/cli.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/cli.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/errors.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/errors.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/gitignore.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/gitignore.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/lookaside.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/lookaside.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/man_gen.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/man_gen.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/sources.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/sources.cpython-37.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/utils.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pyrpkg/__pycache__/utils.cpython-37.pyc
/usr/lib/python3.7/site-packages/rpkg-1.57-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/rpkg-1.57-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/rpkg-1.57-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/rpkg-1.57-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/rpkg-1.57-py3.7.egg-info/top_level.txt
/usr/share/doc/python3-rpkg/CHANGELOG.rst
/usr/share/doc/python3-rpkg/README.rst
/usr/share/licenses/python3-rpkg/COPYING
/usr/share/licenses/python3-rpkg/COPYING-koji
/usr/share/licenses/python3-rpkg/LGPL

Changelog

2019-02-07 - Ondřej Nosek <onosek@redhat.com> - 1.57-6
- Revert previous change.
Now python-gobject-base & libmodulemd are removed from epel7 and RHEL7
2019-02-05 - Ondřej Nosek <onosek@redhat.com> - 1.57-5
- python-gobject-base & libmodulemd also for epel7 and RHEL7
2019-02-04 - Lubomír Sedlář <lsedlar@redhat.com> - 1.57-4
- Disable Py2 package on F30+
2019-02-02 - Fedora Release Engineering <releng@fedoraproject.org> - 1.57-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2019-01-03 - Ondřej Nosek <onosek@redhat.com> - 1.57-2
- Merge changes of the .spec files for Fedora and RHEL
2018-12-13 - Ondřej Nosek <onosek@redhat.com> - 1.57-1
- Use idna 2.7 for Python 2.6 (lsedlar)
- Imports are sorted (onosek)
- libmodulemd is missing on el7 - #402 (onosek)
- Initialize bash autocompletion (onosek)
- Set configuration in case of "clone --branches" as well (tim)
- Fix fake spec file for clog tests (cqi)
- Move argparse fix from fedpkg - #398 (onosek)
- Send source mtime to dist-git - 220 (lsedlar)
- Fix tests for mock package manager (lsedlar)
- Specify package manager for mock-config (lsedlar)
- Add contributing guide (onosek)
- Validate the module build optional argument when parsing the argument
(mprahl)
- Add config options to parse the base module (e.g. platform) stream from the
dist-git branch and apply a buildrequire override (mprahl)
- Add the ability to pass in buildrequire and require overrides on a module
build (mprahl)
- Raise an error if the module build command receives optional arguments that
conflict (mprahl)
- Silence Python3 SafeConfigParser warnings (mmathesi)
- Allow to pass posargs to tox from make (cqi)
- Specify dependent packages in one place (cqi)
- Don't registry flatpak-build command on Python-2.6 (otaylor)
- Add flatpak-build subcommand (otaylor)
- Don't pass the MBS API URL around as a parameter (otaylor)
- TestContainerBuildWithKoji: tear down the mock appropriately (otaylor)
- Refine test runner for py26 (cqi)
2018-09-07 - Owen Taylor <otaylor@redhat.com> - 1.56-2
- Add patch from upstream pull-request to add a flatpak-build subcommand
- Add PyYAML dependencies so that the spec file at least builds on epel6/epel7
2018-08-21 - Chenxiong Qi <cqi@redhat.com> - 1.56-1
- Validate greenwave policy early in Commands.build (cqi)
- Refine error message for failure gating.yaml validation (cqi)
- explain mbs-manager exception handling (nils)
- test for missing mbs-manager with errno set (nils)
- catch errno == ENOENT if mbs-manager is missing (nils)
- add missing method docstring (nils)
- Show full error from MBS (lsedlar)
- Fix tests for greenwave policy validation (cqi)
- Add testenv for building docs (cqi)
- New option --buildrootdir - rhbz#1583822 (cqi)
- Add --shell option to mockbuild - rhbz#1438685 (cqi)
- Validate gating.yaml file for Greenwave gating (gnaponie)
- Update README (cqi)
- Reduce the number of repo creation for tests (cqi)
- Fix flake8 error (cqi)
- Drop rpm-py-installer from requires - #357 (cqi)
- Allow _run_command to capture and return output to stdout or stderr (cqi)
- Claim Python 3.7 in README and package classifiers (cqi)
- Fix a bad test teardown (otaylor)
- Refactor build command (cqi)
- Remove rpmfluff package (cqi)
- Set PYCURL_SSL_LIBRARY directly for installing pycurl (cqi)
- Add py37 testenv (cqi)
2018-07-26 - Chenxiong Qi <cqi@redhat.com> - 1.55-2
- Remove dependency python-rpmfluff

See Also

Package Description
python3-rply-0.7.6-2.fc30.noarch.rpm Port David Beazley's PLY to RPython
python3-rpm-4.14.2.1-4.fc30.1.x86_64.rpm Python 3 bindings for apps which will manipulate RPM packages
python3-rpm-generators-7-2.fc30.noarch.rpm Dependency generators for Python RPMs
python3-rpm-macros-3-42.fc30.noarch.rpm RPM macros for building Python 3 packages
python3-rpmconf-1.0.19-6.fc30.noarch.rpm Python interface for rpmconf
python3-rpmconf-doc-1.0.19-6.fc30.noarch.rpm Documentation of python interface for rpmconf
python3-rpmdeplint-1.4-6.fc30.noarch.rpm Tool to find errors in RPM packages in the context of their dependency graph
python3-rpmfluff-0.5.6-1.fc30.noarch.rpm Lightweight way of building RPMs, and sabotaging them
python3-rpy-3.0.1-2.fc30.noarch.rpm Python interface to the R language
python3-rpyc-4.0.1-3.fc30.noarch.rpm A Transparent, Symmetrical Python Library for Distributed-Computing
python3-rrdtool-1.7.1-1.fc30.x86_64.rpm Python RRDtool bindings
python3-rsa-3.4.2-9.fc30.noarch.rpm Pure-Python RSA implementation
python3-rsd-lib-0.1.1-8.fc30.noarch.rpm Python library for interfacing with Intel Rack Scale Design enabled hardware
python3-rsd-lib-tests-0.1.1-8.fc30.noarch.rpm rsd-lib tests
python3-rsdclient-0.1.1-7.fc30.noarch.rpm OpenStack client plugin for Rack Scale Design
Advertisement
Advertisement