qt-assistant-adp-devel-4.6.3-20.fc30.i686.rpm


Advertisement

Description

qt-assistant-adp-devel - Development files for the compatibility QAssistantClient

Property Value
Distribution Fedora 30
Repository Fedora x86_64
Package filename qt-assistant-adp-devel-4.6.3-20.fc30.i686.rpm
Package name qt-assistant-adp-devel
Package version 4.6.3
Package release 20.fc30
Package architecture i686
Package type rpm
Homepage https://download.qt.io/archive/qt/4.6/
License LGPLv2 with exceptions or GPLv3 with exceptions
Maintainer -
Download size 11.77 KB
Installed size 6.42 KB
This package contains the files necessary to build applications using the
deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
which is used together with the legacy Assistant Document Profile (.adp) version
of Qt Assistant.
This class is obsolete. It is provided to keep old source code working. We
strongly advise against using it in new code. New code should use the Qt Help
Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
(also introduced in Qt 4.4) instead.

Alternatives

Package Version Architecture Repository
qt-assistant-adp-devel-4.6.3-20.fc30.i686.rpm 4.6.3 i686 Fedora
qt-assistant-adp-devel-4.6.3-20.fc30.x86_64.rpm 4.6.3 x86_64 Fedora
qt-assistant-adp-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libQtAssistantClient.so.4 -
pkgconfig(QtNetwork) -
qt-assistant-adp(x86-32) = 4.6.3-20.fc30
qt4-devel -

Provides

Name Value
pkgconfig(QtAssistantClient) = 4.8.7
qt-assistant-adp-devel = 4.6.3-20.fc30
qt-assistant-adp-devel(x86-32) = 4.6.3-20.fc30

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package qt-assistant-adp-devel-4.6.3-20.fc30.i686.rpm
Source Package qt-assistant-adp-4.6.3-20.fc30.src.rpm

Install Howto

Install qt-assistant-adp-devel rpm package:

# dnf install qt-assistant-adp-devel

Files

Path
/usr/include/QtAssistant/QAssistantClient
/usr/include/QtAssistant/QtAssistant
/usr/include/QtAssistant/qassistantclient.h
/usr/include/QtAssistant/qassistantclient_global.h
/usr/lib/libQtAssistantClient.prl
/usr/lib/libQtAssistantClient.so
/usr/lib/libQtAssistantClient_debug.so
/usr/lib/pkgconfig/QtAssistantClient.pc
/usr/lib/qt4/mkspecs/features/assistant.prf

Changelog

2019-02-02 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2018-07-14 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-07-05 - Than Ngo <than@redhat.com> - 4.6.3-18
- fixed source url
2018-03-07 - Rex Dieter <rdieter@fedoraproject.org> - 4.6.3-17
- BR: gcc-c++, use %ldconfig_scriptlets %make_build
2018-02-09 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-11 - Fedora Release Engineering <releng@fedoraproject.org> - 4.6.3-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

See Also

Package Description
qt-at-spi-0.3.1-17.fc30.i686.rpm Qt plugin that bridges Qt's accessibility API to AT-SPI2
qt-at-spi-0.3.1-17.fc30.x86_64.rpm Qt plugin that bridges Qt's accessibility API to AT-SPI2
qt-at-spi-doc-0.3.1-17.fc30.noarch.rpm Documentation for qt-at-spi
qt-common-4.8.7-47.fc30.noarch.rpm Common files for Qt
qt-config-4.8.7-47.fc30.x86_64.rpm Graphical configuration tool for programs using Qt 4
qt-creator-4.9.0-0.1.beta1.fc30.i686.rpm Cross-platform IDE for Qt
qt-creator-4.9.0-0.1.beta1.fc30.x86_64.rpm Cross-platform IDE for Qt
qt-creator-data-4.9.0-0.1.beta1.fc30.noarch.rpm Application data for qt-creator
qt-creator-doc-4.9.0-0.1.beta1.fc30.noarch.rpm User documentation for qt-creator
qt-creator-translations-4.9.0-0.1.beta1.fc30.noarch.rpm Translations for qt-creator
qt-demos-4.8.7-47.fc30.x86_64.rpm Demonstration applications for qt
qt-designer-plugin-webkit-4.8.7-47.fc30.i686.rpm Qt designer plugin for WebKit
qt-designer-plugin-webkit-4.8.7-47.fc30.x86_64.rpm Qt designer plugin for WebKit
qt-devel-4.8.7-47.fc30.i686.rpm Development files for the Qt toolkit
qt-devel-4.8.7-47.fc30.x86_64.rpm Development files for the Qt toolkit
Advertisement
Advertisement