libvma-8.0.1-1.fc25.i686.rpm


Advertisement

Description

libvma - A library for boosting TCP and UDP traffic (over RDMA hardware)

Distribution: Fedora Rawhide
Repository: Fedora x86_64
Package name: libvma
Package version: 8.0.1
Package release: 1.fc25
Package architecture: i686
Package type: rpm
Installed size: 1.40 MB
Download size: 479.93 KB
Official Mirror: dl.fedoraproject.org
libvma is a LD_PRELOAD-able library that boosts performance of TCP and UDP traffic. It allows application written over standard socket API to handle fast path data traffic from user space over Ethernet and/or Infiniband with full network stack bypass and get better throughput, latency and packets/sec rate. No application binary change is required for that. libvma is supported by RDMA capable devices that support "verbs" IBV_QPT_RAW_PACKET QP for Ethernet and/or IBV_QPT_UD QP for IPoIB.

Alternatives

Provides

  • config(libvma) = 8.0.1-1.fc25
  • libvma = 8.0.1-1.fc25
  • libvma(x86-32) = 8.0.1-1.fc25
  • libvma.so.8

    Download

    Install Howto

    Install the libvma rpm package:

    # dnf install libvma

    Files

    • /etc/libvma.conf
    • /etc/security/limits.d/30-libvma-limits.conf
    • /usr/lib/libvma.so
    • /usr/lib/libvma.so.8
    • /usr/lib/libvma.so.8.0.1
    • /usr/share/doc/libvma/README.txt
    • /usr/share/doc/libvma/VMA_VERSION
    • /usr/share/doc/libvma/journal.txt
    • /usr/share/licenses/libvma/COPYING
    • /usr/share/licenses/libvma/LICENSE

    Changelog

    2016-03-13 - Alex Vainman <alexv@mellanox.com> - 8.0.1-1 - New upstream release - Move to dual license: GPLv2 or BSD - ExcludeArch update - Removal of extra space in: config(noreplace) {_sysconfdir}/security/limits.d/30-libvma-limits.conf - Add V=1 to make

    2016-03-02 - Alex Vainman <alexv@mellanox.com> - 7.0.14-2 - Added reasoning for archs exclusion - Package description improvement - Removal of the pre scriplet - Added COPYING and LICENSE files to the package

    2016-02-21 - Alex Vainman <alexv@mellanox.com> - 7.0.14-1 - New upstream release - Removal of redundant macros and obsolete/unneeded tags - Added ExcludeArch, BuildRequires and Require sections - Fixes and cleanups in the build and installation sections - Install 30-libvma-limits.conf file under /etc/security/limits.d/ - Fixes related to files/directories ownerships - Removal of vma_perf_envelope.sh from the utility package - Update Source tag URL - Fix most of the rpmlint warnings

    2016-01-04 - Avner BenHanoch <avnerb@mellanox.com> - 7.0.12-1 - Initial Packaging

    Advertisement
    Advertisement