needrestart-3.4-3.fc32.noarch.rpm


Advertisement

Description

needrestart - Restart daemons after library updates

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package filename needrestart-3.4-3.fc32.noarch.rpm
Package name needrestart
Package version 3.4
Package release 3.fc32
Package architecture noarch
Package type rpm
Homepage https://github.com/liske/needrestart
License GPLv2+
Maintainer -
Download size 70.22 KB
Installed size 222.06 KB
needrestart checks which daemons need to be restarted after library
upgrades. It is inspired by checkrestart from the debian-goodies
package.

Alternatives

Package Version Architecture Repository
needrestart - - -

Requires

Name Value
/usr/bin/perl -
/usr/bin/sh -
iucode-tool -
perl(Debconf::Client::ConfModule) -
perl(Locale::TextDomain) -
perl(Module::Find) -
perl(Module::ScanDeps) -
perl(Proc::ProcessTable) -
perl(Sort::Naturally) -
perl(Term::ReadKey) -
python(abi) = 3.8
python3-dnf -
xz -

Provides

Name Value
config(needrestart) = 3.4-3.fc32
needrestart = 3.4-3.fc32

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package needrestart-3.4-3.fc32.noarch.rpm
Source Package needrestart-3.4-3.fc32.src.rpm

Install Howto

Install needrestart rpm package:

# dnf install needrestart

Files

Path
/etc/default/intel-microcode
/etc/dnf/plugins/needrestart.conf
/etc/needrestart/needrestart.conf
/etc/needrestart/notify.conf
/etc/needrestart/conf.d/README.needrestart
/etc/needrestart/hook.d/10-dpkg
/etc/needrestart/hook.d/30-pacman
/etc/needrestart/hook.d/90-none
/etc/needrestart/notify.d/200-write
/etc/needrestart/notify.d/400-notify-send
/etc/needrestart/notify.d/600-mail
/etc/needrestart/notify.d/README.needrestart
/etc/needrestart/restart.d/README.needrestart
/etc/needrestart/restart.d/auditd.service
/etc/needrestart/restart.d/dbus.service
/etc/needrestart/restart.d/systemd-manager
/etc/needrestart/restart.d/sysv-init
/usr/lib/needrestart/iucode-scan-versions
/usr/lib/needrestart/notify.d.sh
/usr/lib/needrestart/vmlinuz-get-version
/usr/lib/python3.8/site-packages/dnf-plugins/needrestart.py
/usr/sbin/needrestart
/usr/share/doc/needrestart/ChangeLog
/usr/share/doc/needrestart/NEWS
/usr/share/doc/needrestart/README.Cont.md
/usr/share/doc/needrestart/README.Interp.md
/usr/share/doc/needrestart/README.batch.md
/usr/share/doc/needrestart/README.md
/usr/share/doc/needrestart/README.nagios.md
/usr/share/doc/needrestart/README.uCode.md
/usr/share/licenses/needrestart/COPYING
/usr/share/locale/cs/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/cs/LC_MESSAGES/needrestart.mo
/usr/share/locale/de/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/de/LC_MESSAGES/needrestart.mo
/usr/share/locale/ru/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/ru/LC_MESSAGES/needrestart.mo
/usr/share/man/man1/needrestart.1.gz
/usr/share/needrestart/needrestart.templates
/usr/share/perl5/vendor_perl/NeedRestart.pm
/usr/share/perl5/vendor_perl/NeedRestart/CONT.pm
/usr/share/perl5/vendor_perl/NeedRestart/Interp.pm
/usr/share/perl5/vendor_perl/NeedRestart/Kernel.pm
/usr/share/perl5/vendor_perl/NeedRestart/Strings.pm
/usr/share/perl5/vendor_perl/NeedRestart/UI.pm
/usr/share/perl5/vendor_perl/NeedRestart/Utils.pm
/usr/share/perl5/vendor_perl/NeedRestart/uCode.pm
/usr/share/perl5/vendor_perl/NeedRestart/CONT/LXC.pm
/usr/share/perl5/vendor_perl/NeedRestart/CONT/docker.pm
/usr/share/perl5/vendor_perl/NeedRestart/CONT/machined.pm
/usr/share/perl5/vendor_perl/NeedRestart/Interp/Java.pm
/usr/share/perl5/vendor_perl/NeedRestart/Interp/Perl.pm
/usr/share/perl5/vendor_perl/NeedRestart/Interp/Python.pm
/usr/share/perl5/vendor_perl/NeedRestart/Interp/Ruby.pm
/usr/share/perl5/vendor_perl/NeedRestart/Kernel/Linux.pm
/usr/share/perl5/vendor_perl/NeedRestart/Kernel/kFreeBSD.pm
/usr/share/perl5/vendor_perl/NeedRestart/UI/Debconf.pm
/usr/share/perl5/vendor_perl/NeedRestart/UI/stdio.pm
/usr/share/perl5/vendor_perl/NeedRestart/uCode/Intel.pm
/usr/share/polkit-1/
/usr/share/polkit-1/actions/net.fiasko-nw.needrestart.policy

Changelog

2019-08-19 - Miro Hrončok <mhroncok@redhat.com> - 3.4-3
- Rebuilt for Python 3.8
2019-07-25 - Fedora Release Engineering <releng@fedoraproject.org> - 3.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
2019-05-24 - Marc Dequènes (Duck) <duck@redhat.com> - 3.4-1
- NUR
- backport patch to blacklist the network service; accepted
upstream but not yet released
- remove workaround related to terminal size detection in
a non-interractive situation, fixed upstream
(see https://github.com/liske/needrestart/pull/110)
- update debconf templates
2019-04-02 - Marc Dequènes (Duck) <duck@redhat.com> - 3.3-3
- limit Python files to the actual plugin, thus avoiding to embed Python
bytecode and also owning the general Python lib path by mistake
(fixes #1672094)
2019-02-01 - Fedora Release Engineering <releng@fedoraproject.org> - 3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2018-07-19 - Marc Dequènes (Duck) <duck@redhat.com> - 3.3-1
- NUR
- YUM plugin: use subprocess32 as recommended by Python
subprocess documentation, and catch all exceptions
- removes the `20-rpm` hook, this is breaking the RPM DB
- workaround needrestart#123
- add missing dependency on 'iucode-tool'
- install new documentation file 'README.uCode.md'
- update debconf templates
- NUR: removed all patches, integrated upstream
- added workaround for GetTerminalSize problem when used
non-interractively (see needrestart#110)
- fix crash with YUM plugin when called by yum-cron
2018-07-13 - Fedora Release Engineering <releng@fedoraproject.org> - 2.11-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-19 - Miro Hrončok <mhroncok@redhat.com> - 2.11-10
- Rebuilt for Python 3.7
2018-02-08 - Fedora Release Engineering <releng@fedoraproject.org> - 2.11-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-12-21 - Marc Dequènes (Duck) <duck@redhat.com> - 2.11-8
- fix 'check_needed' variable scope in YUM plugin
- fix YUM plugin Python encoding problem
- declare YUM plugin can be run non-interactively
- YUM/DNF plugins: run non-interactively if --assumeyes is used

See Also

Package Description
nekobee-dssi-0.1.7-22.fc31.x86_64.rpm Acid sounds synthesizer
nekohtml-1.9.22-10.fc31.noarch.rpm HTML scanner and tag balancer
nekohtml-demo-1.9.22-10.fc31.noarch.rpm Demo for nekohtml
nekohtml-javadoc-1.9.22-10.fc31.noarch.rpm Javadoc for nekohtml
nekovm-2.2.0-11.fc31.i686.rpm Neko embedded scripting language and virtual machine
nekovm-2.2.0-11.fc31.x86_64.rpm Neko embedded scripting language and virtual machine
nekovm-devel-2.2.0-11.fc31.i686.rpm Development files for nekovm
nekovm-devel-2.2.0-11.fc31.x86_64.rpm Development files for nekovm
nemiver-0.9.6-13.fc31.x86_64.rpm A GNOME C/C++ Debugger
nemo-4.2.3-2.fc32.i686.rpm File manager for Cinnamon
nemo-4.2.3-2.fc32.x86_64.rpm File manager for Cinnamon
nemo-compare-4.2.0-4.fc32.noarch.rpm Context menu comparison extension for nemo
nemo-devel-4.2.3-2.fc32.i686.rpm Support for developing nemo extensions
nemo-devel-4.2.3-2.fc32.x86_64.rpm Support for developing nemo extensions
nemo-emblems-4.2.0-4.fc32.noarch.rpm Emblem support for nemo
Advertisement
Advertisement