php-symfony4-phpunit-bridge-4.2.11-1.fc32.noarch.rpm


Advertisement

Description

php-symfony4-phpunit-bridge - Symfony PHPUnit Bridge (version 4)

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package filename php-symfony4-phpunit-bridge-4.2.11-1.fc32.noarch.rpm
Package name php-symfony4-phpunit-bridge
Package version 4.2.11
Package release 1.fc32
Package architecture noarch
Package type rpm
Homepage https://symfony.com
License MIT
Maintainer -
Download size 39.95 KB
Installed size 98.21 KB
Provides utilities for PHPUnit, especially user deprecation notices management.
It comes with the following features:
* disable the garbage collector
* auto-register class_exists to load Doctrine annotations
* print a user deprecation notices summary at the end of the test suite.
Autoloader: /usr/share/php/Symfony4/Bridge/PhpUnit/autoload.php

Alternatives

Package Version Architecture Repository
php-symfony4-phpunit-bridge - - -

Requires

Name Value
/usr/bin/php -
php-date -
php-pcre -
php-posix -
php-reflection -
php-symfony4-common = 4.2.11-1.fc32

Provides

Name Value
php-composer(symfony/phpunit-bridge) = 4.2.11
php-symfony4-phpunit-bridge = 4.2.11-1.fc32

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package php-symfony4-phpunit-bridge-4.2.11-1.fc32.noarch.rpm
Source Package php-symfony4-4.2.11-1.fc32.src.rpm

Install Howto

Install php-symfony4-phpunit-bridge rpm package:

# dnf install php-symfony4-phpunit-bridge

Files

Path
/usr/share/doc/php-symfony4-phpunit-bridge/CHANGELOG.md
/usr/share/doc/php-symfony4-phpunit-bridge/README.md
/usr/share/doc/php-symfony4-phpunit-bridge/composer.json
/usr/share/licenses/php-symfony4-phpunit-bridge/LICENSE
/usr/share/php/Symfony4/Bridge/PhpUnit/ClockMock.php
/usr/share/php/Symfony4/Bridge/PhpUnit/CoverageListener.php
/usr/share/php/Symfony4/Bridge/PhpUnit/DeprecationErrorHandler.php
/usr/share/php/Symfony4/Bridge/PhpUnit/DnsMock.php
/usr/share/php/Symfony4/Bridge/PhpUnit/SymfonyTestsListener.php
/usr/share/php/Symfony4/Bridge/PhpUnit/autoload.php
/usr/share/php/Symfony4/Bridge/PhpUnit/bootstrap.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CommandForV5.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CommandForV6.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CoverageListenerForV5.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CoverageListenerForV6.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CoverageListenerForV7.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/CoverageListenerTrait.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV5.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV6.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/SymfonyTestsListenerForV7.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Legacy/SymfonyTestsListenerTrait.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/ClockMockTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/CoverageListenerTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DnsMockTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/ProcessIsolationTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/default.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/deprecation.phar
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/disabled.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/generate_phar.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/regexp.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/shutdown_deprecations.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_eval_d_deprecation.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_non_vendor.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_phar_deprecation.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/weak_vendors_on_vendor.phpt
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/deprecation/deprecation.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/fake_vendor/autoload.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/fake_vendor/acme/
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/fake_vendor/acme/lib/deprecation_riddled.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/fake_vendor/composer/autoload_real.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/DeprecationErrorHandler/fake_vendor/composer/installed.json
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/phpunit-with-listener.xml.dist
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/phpunit-without-listener.xml.dist
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/src/BarCov.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/src/FooCov.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/BarCovTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/CoversDefaultClassTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/CoversNothingTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/CoversTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/SutNotFindTest.php
/usr/share/php/Symfony4/Bridge/PhpUnit/Tests/Fixtures/coverage/tests/bootstrap.php
/usr/share/php/Symfony4/Bridge/PhpUnit/TextUI/Command.php
/usr/share/php/Symfony4/Bridge/PhpUnit/bin/simple-phpunit

Changelog

2019-08-20 - Remi Collet <remi@remirepo.net> - 4.2.11-1
- update to 4.2.11
2019-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 4.2.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
2019-06-04 - Remi Collet <remi@remirepo.net> - 4.2.9-1
- update to 4.2.9
- raise dependency on twig 1.41
- raise dependency on contracts 1.1.1
2019-05-02 - Remi Collet <remi@remirepo.net> - 4.2.8-1
- update to 4.2.8
- raise dependency on twig 1.40
2019-04-18 - Remi Collet <remi@remirepo.net> - 4.2.7-2
- validator requires translation (from Koschei)
2019-04-18 - Remi Collet <remi@remirepo.net> - 4.2.7-1
- update to 4.2.7
2019-04-16 - Remi Collet <remi@remirepo.net> - 4.2.6-1
- update to 4.2.6
2019-04-03 - Remi Collet <remi@remirepo.net> - 4.2.5-1
- update to 4.2.5
- raise dependency on twig 1.38.1
2019-03-04 - Remi Collet <remi@remirepo.net> - 4.2.4-1
- update to 4.2.4
2019-02-04 - Remi Collet <remi@remirepo.net> - 4.2.3-1
- update to 4.2.3
- raise dependency on twig 1.37.1
- add new symfony/var-exporter component
- add dependency on symfony/contracts
- add dependency on doctrine/event-manager, doctrine/persistence
and doctrine/reflection
- raise dependency on doctrine/dbal 2.5
- raise dependency on ocramius/proxy-manager 2.1

See Also

Package Description
php-symfony4-process-4.2.11-1.fc32.noarch.rpm Symfony Process Component (version 4)
php-symfony4-property-access-4.2.11-1.fc32.noarch.rpm Symfony PropertyAccess Component (version 4)
php-symfony4-property-info-4.2.11-1.fc32.noarch.rpm Symfony PropertyInfo Component (version 4)
php-symfony4-proxy-manager-bridge-4.2.11-1.fc32.noarch.rpm Symfony ProxyManager Bridge (version 4)
php-symfony4-routing-4.2.11-1.fc32.noarch.rpm Symfony Routing Component (version 4)
php-symfony4-security-4.2.11-1.fc32.noarch.rpm Symfony Security Component (version 4)
php-symfony4-security-bundle-4.2.11-1.fc32.noarch.rpm Symfony Security Bundle (version 4)
php-symfony4-serializer-4.2.11-1.fc32.noarch.rpm Symfony Serializer Component (version 4)
php-symfony4-stopwatch-4.2.11-1.fc32.noarch.rpm Symfony Stopwatch Component (version 4)
php-symfony4-templating-4.2.11-1.fc32.noarch.rpm Symfony Templating Component (version 4)
php-symfony4-translation-4.2.11-1.fc32.noarch.rpm Symfony Translation Component (version 4)
php-symfony4-twig-bridge-4.2.11-1.fc32.noarch.rpm Symfony Twig Bridge (version 4)
php-symfony4-twig-bundle-4.2.11-1.fc32.noarch.rpm Symfony Twig Bundle (version 4)
php-symfony4-validator-4.2.11-1.fc32.noarch.rpm Symfony Validator Component (version 4)
php-symfony4-var-dumper-4.2.11-1.fc32.noarch.rpm Symfony mechanism for exploring and dumping PHP variables (version 4)
Advertisement
Advertisement