ruby-gnome2-0.90.4-8.fc29.x86_64.rpm


Advertisement

Description

ruby-gnome2 - Ruby binding of libgnome/libgnomeui-2.x

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package name ruby-gnome2
Package version 0.90.4
Package release 8.fc29
Package architecture x86_64
Package type rpm
Installed size 365.06 KB
Download size 114.77 KB
Official Mirror dl.fedoraproject.org
Ruby/GNOME2 is a Ruby binding of libgnome/libgnomeui-2.x.

Alternatives

Package Version Architecture Repository
ruby-gnome2 - - -

Requires

Name Value
libICE.so.6()(64bit) -
libORBit-2.so.0()(64bit) -
libSM.so.6()(64bit) -
libart_lgpl_2.so.2()(64bit) -
libatk-1.0.so.0()(64bit) -
libbonobo-2.so.0()(64bit) -
libbonobo-activation.so.4()(64bit) -
libbonoboui-2.so.0()(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcairo.so.2()(64bit) -
libcrypt.so.1()(64bit) -
libdl.so.2()(64bit) -
libfontconfig.so.1()(64bit) -
libfreetype.so.6()(64bit) -
libgconf-2.so.4()(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgnome-2.so.0()(64bit) -
libgnomecanvas-2.so.0()(64bit) -
libgnomeui-2.so.0()(64bit) -
libgnomevfs-2.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgthread-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libpango-1.0.so.0()(64bit) -
libpangocairo-1.0.so.0()(64bit) -
libpangoft2-1.0.so.0()(64bit) -
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
libpthread.so.0()(64bit) -
libruby.so.2.5()(64bit) -
rtld(GNU_HASH) -
ruby(gnomecanvas2) = 0.90.4-8.fc29
ruby(release) -

Provides

Name Value
ruby(gnome2) = 0.90.4-8.fc29
ruby-gnome2 = 0.90.4-8.fc29
ruby-gnome2(x86-64) = 0.90.4-8.fc29

Obsoletes

Name Value
ruby(gnomeprint2) <= 0.90.4-8.fc29
ruby(gnomeprint2-devel) <= 0.90.4-8.fc29
ruby(gnomeprintui2) <= 0.90.4-8.fc29
ruby(gnomeprintui2-devel) <= 0.90.4-8.fc29
ruby(goocanvas) <= 0.90.4-8.fc29
ruby(goocanvas-devel) <= 0.90.4-8.fc29
ruby(gstreamer) <= 0.90.4-8.fc29
ruby(gstreamer-devel) <= 0.90.4-8.fc29
ruby(gtkhtml2) <= 0.90.4-8.fc29
ruby(gtkhtml2-devel) <= 0.90.4-8.fc29
ruby(gtkmozembed) <= 0.90.4-8.fc29
ruby(gtkmozembed-devel) <= 0.90.4-8.fc29
ruby(gtksourceview) <= 0.90.4-8.fc29
ruby(gtksourceview-devel) <= 0.90.4-8.fc29
ruby(panelapplet2) <= 0.90.4-8.fc29
ruby(panelapplet2-devel) <= 0.90.4-8.fc29

Download

Type URL
Binary Package ruby-gnome2-0.90.4-8.fc29.x86_64.rpm
Source Package ruby-gnome2-0.90.4-8.fc29.src.rpm

Install Howto

Install the ruby-gnome2 rpm package:

# dnf install ruby-gnome2

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/d2/6da222f03f8b666f447cc0daf7226759357055
/usr/lib64/ruby/vendor_ruby/gnome2.so
/usr/share/doc/ruby-gnome2/AUTHORS
/usr/share/doc/ruby-gnome2/COPYING.LIB
/usr/share/doc/ruby-gnome2/ChangeLog
/usr/share/doc/ruby-gnome2/NEWS
/usr/share/doc/ruby-gnome2/README
/usr/share/doc/ruby-gnome2/sample/gnome-app-helper.rb
/usr/share/doc/ruby-gnome2/sample/gnome-config.rb
/usr/share/doc/ruby-gnome2/sample/gnome-druid.rb
/usr/share/doc/ruby-gnome2/sample/gnome-program.rb
/usr/share/doc/ruby-gnome2/sample/gnome-sound.rb
/usr/share/doc/ruby-gnome2/sample/gnome-trigger.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/README
/usr/share/doc/ruby-gnome2/sample/test-gnome/about.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/app-helper.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/bomb.xpm
/usr/share/doc/ruby-gnome2/sample/test-gnome/color-picker.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/dateedit.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/entry.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/file-entry.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/font-picker.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/href.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/icon-entry.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/icon-list.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/pixmap-entry.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/test-gnome-app.rb
/usr/share/doc/ruby-gnome2/sample/test-gnome/test-gnome.rb
/usr/share/ruby/vendor_ruby/gnome2.rb

Changelog

2018-03-02 - Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.90.4-8
- Kill gtksourceview2 subpackage, already suplied by other package
2018-02-14 - Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.90.4-7.9
- Fix build error on libart with gcc8 -O2 + ruby 2.5
2018-02-09 - Fedora Release Engineering <releng@fedoraproject.org> - 0.90.4-7.8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2018-01-20 - Björn Esser <besser82@fedoraproject.org> - 0.90.4-7.7
- Rebuilt for switch to libxcrypt
2018-01-04 - Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.90.4-7.6
- F-28: rebuild for ruby25
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 0.90.4-7.5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 0.90.4-7.4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-11 - Fedora Release Engineering <releng@fedoraproject.org> - 0.90.4-7.3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2017-01-11 - Mamoru TASAKA <mtasaka@fedoraproject.org> - 0.90.4-7.2
- F-26: rebuild for ruby24
2016-02-04 - Fedora Release Engineering <releng@fedoraproject.org> - 0.90.4-7.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

See Also

Package Description
ruby-gnome2-devel-0.90.4-8.fc29.i686.rpm Development libraries and header files for ruby-gnome2
ruby-gnome2-devel-0.90.4-8.fc29.x86_64.rpm Development libraries and header files for ruby-gnome2
ruby-gnomecanvas2-0.90.4-8.fc29.x86_64.rpm Ruby binding of GnomeCanvas-2.x
ruby-gnomecanvas2-devel-0.90.4-8.fc29.i686.rpm Development libraries and header files for ruby-gnomecanvas2
ruby-gnomecanvas2-devel-0.90.4-8.fc29.x86_64.rpm Development libraries and header files for ruby-gnomecanvas2
ruby-gnomevfs-0.90.4-8.fc29.x86_64.rpm Ruby binding of GnomeVFS-2.0.x
ruby-gnomevfs-devel-0.90.4-8.fc29.i686.rpm Development libraries and header files for ruby-gnomevfs
ruby-gnomevfs-devel-0.90.4-8.fc29.x86_64.rpm Development libraries and header files for ruby-gnomevfs
ruby-gtkglext-0.90.4-8.fc29.x86_64.rpm Ruby binding of GtkGLExt
ruby-gtkglext-devel-0.90.4-8.fc29.i686.rpm Development libraries and header files for ruby-gtkglext
ruby-gtkglext-devel-0.90.4-8.fc29.x86_64.rpm Development libraries and header files for ruby-gtkglext
ruby-hivex-1.3.15-11.fc29.x86_64.rpm Ruby bindings for hivex
ruby-hyperestraier-1.4.13-33.fc29.x86_64.rpm Hyper Estraier Library for Ruby
ruby-icon-artist-0.1.92-16.fc29.noarch.rpm Supporting libraries for icon artists
ruby-irb-2.5.1-93.fc29.noarch.rpm The Interactive Ruby
Advertisement
Advertisement