rubygem-puppet-lint-1.1.0-2.fc23.noarch.rpm


Advertisement

Description

rubygem-puppet-lint - Ensure your Puppet manifests conform with the Puppetlabs style guide

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package name rubygem-puppet-lint
Package version 1.1.0
Package release 2.fc23
Package architecture noarch
Package type rpm
Installed size 89.29 KB
Download size 34.79 KB
Official Mirror dl.fedoraproject.org
Checks your Puppet manifests against the Puppetlabs
style guide and alerts you to any discrepancies.

Alternatives

Package Version Architecture Repository
rubygem-puppet-lint - - -

Requires

Name Value
/usr/bin/env -
/usr/bin/ruby -
ruby(release) -
ruby(rubygems) -

Provides

Name Value
rubygem(puppet-lint) = 1.1.0
rubygem(puppet-lint) = 1.1.0-1
rubygem-puppet-lint = 1.1.0-2.fc23

Download

Type URL
Binary Package rubygem-puppet-lint-1.1.0-2.fc23.noarch.rpm
Source Package rubygem-puppet-lint-1.1.0-2.fc23.src.rpm

Install Howto

Install the rubygem-puppet-lint rpm package:

# dnf install rubygem-puppet-lint

Files

Path
/usr/bin/puppet-lint
/usr/share/gems/gems/puppet-lint-1.1.0/Gemfile
/usr/share/gems/gems/puppet-lint-1.1.0/LICENSE
/usr/share/gems/gems/puppet-lint-1.1.0/bin/puppet-lint
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/bin.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/checkplugin.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/checks.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/configuration.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/data.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/lexer.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/monkeypatches.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/optparser.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/version.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/lexer/token.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/monkeypatches/string_percent.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/monkeypatches/string_prepend.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_classes.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_comments.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_conditionals.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_documentation.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_nodes.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_resources.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_strings.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_variables.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/plugins/check_whitespace.rb
/usr/share/gems/gems/puppet-lint-1.1.0/lib/puppet-lint/tasks/puppet-lint.rb
/usr/share/gems/specifications/puppet-lint-1.1.0.gemspec

Changelog

2015-06-18 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2015-01-14 - Russell Harrison <rharrison@fedoraproject.org> 1.1.0-1
- Upstream update to 1.1.0
2014-06-08 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2013-08-04 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
2013-03-14 - Russell Harrison <rharrison@fedoraproject.org> 0.3.2-3
- Update for Ruby 2.0 in F19+
2013-02-14 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
2012-10-30 - Russell Harrison <rharrison@fedoraproject.org> 0.3.2-1
- New upstream version. http://puppet-lint.com/changelog/
- Remove exit code patch. Fixed in upstream
2012-09-25 - Russell Harrison <rharrison@fedoraproject.org> 0.2.1-3
- Drop requirement for the puppet package
- Pull in all of rspec as build requires
- Moving files not required at run time to the doc subpackage
- Excluding files not meant for packaging instead of removing them durring install
- Other fixes requested durring package review
2012-09-12 - Russell Harrison <rharrison@fedoraproject.org> 0.2.1-2
- Patch to pass exit value to the shell https://github.com/rodjek/puppet-lint/pull/141
2012-09-07 - Russell Harrison <rharrison@fedoraproject.org> - 0.2.1-1
- New upstream version
- Updated URL for new upstream website

See Also

Package Description
rubygem-puppet-lint-doc-1.1.0-2.fc23.noarch.rpm Documentation for rubygem-puppet-lint
rubygem-qpid_messaging-1.38.0-2.fc29.x86_64.rpm Ruby bindings for the Qpid messaging framework
rubygem-qpid_messaging-doc-1.38.0-2.fc29.noarch.rpm Documentation for rubygem-qpid_messaging
rubygem-qpid_proton-0.24.0-1.fc29.x86_64.rpm Ruby language bindings for the Qpid Proton messaging framework
rubygem-qpid_proton-doc-0.24.0-1.fc29.noarch.rpm Documentation for rubygem-qpid_proton
rubygem-rabbit-2.2.1-4.fc29.noarch.rpm RD-document-based presentation application
rubygem-rabbit-doc-2.2.1-4.fc29.noarch.rpm Documentation for rubygem-rabbit
rubygem-rabl-0.11.0-7.fc29.noarch.rpm General Ruby templating with JSON, BSON, XML and MessagePack support
rubygem-rabl-doc-0.11.0-7.fc29.noarch.rpm Documentation for rubygem-rabl
rubygem-racc-1.4.14-10.fc29.x86_64.rpm LALR(1) parser generator
rubygem-racc-doc-1.4.14-10.fc29.noarch.rpm Documentation for rubygem-racc
rubygem-rack-2.0.4-3.fc29.noarch.rpm A modular Ruby webserver interface
rubygem-rack-accept-0.4.5-7.fc29.noarch.rpm HTTP Accept* for Ruby/Rack
rubygem-rack-accept-doc-0.4.5-7.fc29.noarch.rpm Documentation for rack-accept
rubygem-rack-attack-5.0.1-3.fc29.noarch.rpm Block & throttle abusive requests
Advertisement
Advertisement