rubygem-virtus-1.0.5-1.fc23.noarch.rpm


Advertisement

Description

rubygem-virtus - Attributes on Steroids for Plain Old Ruby Objects

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package name rubygem-virtus
Package version 1.0.5
Package release 1.fc23
Package architecture noarch
Package type rpm
Installed size 76.05 KB
Download size 31.02 KB
Official Mirror dl.fedoraproject.org
Attributes on Steroids for Plain Old Ruby Objects.

Alternatives

Package Version Architecture Repository
rubygem-virtus - - -

Requires

Name Value
ruby(rubygems) -
rubygem(axiom-types) >= 0.1
rubygem(axiom-types) < 1
rubygem(coercible) >= 1.0
rubygem(coercible) < 2
rubygem(descendants_tracker) -
rubygem(descendants_tracker) >= 0.0.3
rubygem(descendants_tracker) < 1
rubygem(equalizer) -
rubygem(equalizer) >= 0.0.9
rubygem(equalizer) < 1

Provides

Name Value
rubygem(virtus) = 1.0.5-1
rubygem-virtus = 1.0.5-1.fc23

Download

Type URL
Binary Package rubygem-virtus-1.0.5-1.fc23.noarch.rpm
Source Package rubygem-virtus-1.0.5-1.fc23.src.rpm

Install Howto

Install the rubygem-virtus rpm package:

# dnf install rubygem-virtus

Files

Path
/usr/share/gems/gems/virtus-1.0.5/LICENSE
/usr/share/gems/gems/virtus-1.0.5/lib/virtus.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute_set.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/builder.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/class_inclusions.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/class_methods.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/coercer.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/configuration.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/const_missing_extensions.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/extensions.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/instance_methods.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/model.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/module_extensions.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/value_object.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/version.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/accessor.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/boolean.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/builder.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/coercer.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/coercible.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/collection.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/default_value.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/embedded_value.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/hash.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/lazy_default.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/nullify_blank.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/strict.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/default_value/from_callable.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/default_value/from_clonable.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/attribute/default_value/from_symbol.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/builder/hook_context.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/support/equalizer.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/support/options.rb
/usr/share/gems/gems/virtus-1.0.5/lib/virtus/support/type_lookup.rb
/usr/share/gems/specifications/virtus-1.0.5.gemspec

Changelog

2015-03-25 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.5-1
- Update to latest upstream version (RHBZ #1203258)
2015-01-04 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.4-1
- Update to latest upstream version (RHBZ #1178430)
2014-12-17 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.3-3
- rspec-its is now available (RHBZ #1168743). Re-enable tests during %check.
2014-11-29 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.3-2
- Simplify %check section
2014-11-29 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.3-1
- Update to latest upstream version (RHBZ #1124269)
- Use %license macro for LICENSE
- Unconditionally pass tests (rspec 3 does not have "its" available)
2014-06-08 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2014-03-14 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.2-1
- Update to latest upstream version (RHBZ #1076588)
2014-02-10 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.1-4
- Adjust comments to reflect that activerecord-nulldb-adapter is now in Fedora
and bogus is the latest missing dependency for the test suite.
- Adjust axiom-types dependency to allow latest version in Rawhide.
2014-02-05 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.1-3
- Adjust comments to reflect that dependor is now in Fedora and
activerecord-nulldb-adapter is the latest missing dependency for the bogus
gem.
2013-12-10 - Ken Dreyer <ktdreyer@ktdreyer.com> - 1.0.1-2
- Adjust coercible version dependency specification to match upstream gemspec

See Also

Package Description
rubygem-virtus-doc-1.0.5-1.fc23.noarch.rpm Documentation for rubygem-virtus
rubygem-vte-3.2.7-1.fc29.x86_64.rpm Ruby binding of vte
rubygem-vte-devel-3.2.7-1.fc29.i686.rpm Ruby/VTE development environment
rubygem-vte-devel-3.2.7-1.fc29.x86_64.rpm Ruby/VTE development environment
rubygem-vte-doc-3.2.7-1.fc29.x86_64.rpm Documentation for rubygem-vte
rubygem-vte3-3.2.7-1.fc29.noarch.rpm Ruby binding of VTE
rubygem-vte3-doc-3.2.7-1.fc29.noarch.rpm Documentation for rubygem-vte3
rubygem-warden-1.2.7-3.fc28.noarch.rpm Rack middle-ware that provides authentication for rack applications
rubygem-warden-doc-1.2.7-3.fc28.noarch.rpm Documentation for rubygem-warden
rubygem-web-console-3.5.1-3.fc28.noarch.rpm A debugging tool for your Ruby on Rails applications
rubygem-web-console-doc-3.5.1-3.fc28.noarch.rpm Documentation for rubygem-web-console
rubygem-webkit2-gtk-3.2.7-1.fc29.noarch.rpm Ruby binding of WebKit2GTK+
rubygem-webkit2-gtk-doc-3.2.7-1.fc29.noarch.rpm Documentation for rubygem-webkit2-gtk
rubygem-webmock-2.3.2-3.fc28.noarch.rpm Library for stubbing HTTP requests in Ruby
rubygem-webmock-doc-2.3.2-3.fc28.noarch.rpm Documentation for rubygem-webmock
Advertisement
Advertisement