sssd-tools-2.1.0-2.fc31.x86_64.rpm


Advertisement

Description

sssd-tools - Userspace tools for use with the SSSD

Property Value
Distribution Fedora Rawhide
Repository Fedora x86_64
Package filename sssd-tools-2.1.0-2.fc31.x86_64.rpm
Package name sssd-tools
Package version 2.1.0
Package release 2.fc31
Package architecture x86_64
Package type rpm
Homepage https://pagure.io/SSSD/sssd/
License GPLv3+
Maintainer -
Download size 217.95 KB
Installed size 474.73 KB
Provides userspace tools for manipulating users, groups, and nested groups in
SSSD when using id_provider = local in /etc/sssd/sssd.conf.
Also provides several other administrative tools:
* sss_debuglevel to change the debug level on the fly
* sss_seed which pre-creates a user entry for use in kickstarts
* sss_obfuscate for generating an obfuscated LDAP password
* sssctl -- an sssd status and control utility

Alternatives

Package Version Architecture Repository
sssd-tools - - -

Requires

Name Value
/usr/bin/python3 -
/usr/bin/sh -
libc.so.6(GLIBC_2.7)(64bit) -
libdhash.so.1()(64bit) -
libdhash.so.1(DHASH_0.4.3)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libifp_iface_sync.so()(64bit) -
libini_config.so.5()(64bit) -
libini_config.so.5(INI_CONFIG_1.3.0)(64bit) -
libldb.so.1()(64bit) -
libldb.so.1(LDB_0.9.10)(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
libpam_misc.so.0()(64bit) -
libpam_misc.so.0(LIBPAM_MISC_1.0)(64bit) -
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
libref_array.so.1()(64bit) -
libref_array.so.1(REF_ARRAY_0.1.1)(64bit) -
libsss_crypt.so()(64bit) -
libsss_debug.so()(64bit) -
libsss_iface_sync.so()(64bit) -
libsss_sbus_sync.so()(64bit) -
libsss_util.so()(64bit) -
libtalloc.so.2()(64bit) -
libtalloc.so.2(TALLOC_2.0.2)(64bit) -
python3-sss = 2.1.0-2.fc31
python3-sssdconfig = 2.1.0-2.fc31
rtld(GNU_HASH) -
sssd-common = 2.1.0-2.fc31

Provides

Name Value
sssd-tools = 2.1.0-2.fc31
sssd-tools(x86-64) = 2.1.0-2.fc31

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package sssd-tools-2.1.0-2.fc31.x86_64.rpm
Source Package sssd-2.1.0-2.fc31.src.rpm

Install Howto

Install sssd-tools rpm package:

# dnf install sssd-tools

Files

Path
/usr/lib/.build-id/
/usr/lib/.build-id/18/6e965c0cdea95db319b454b391157c5bd5cd83
/usr/lib/.build-id/37/eb597edf64bea3bb208247063fa15fdc99b623
/usr/lib/.build-id/75/f505727e10c4da9c4c2abca0ab77996cd4a780
/usr/sbin/sss_debuglevel
/usr/sbin/sss_obfuscate
/usr/sbin/sss_override
/usr/sbin/sss_seed
/usr/sbin/sssctl
/usr/share/licenses/sssd-tools/COPYING
/usr/share/man/ca/man8/sss_groupadd.8.gz
/usr/share/man/ca/man8/sss_groupdel.8.gz
/usr/share/man/ca/man8/sss_groupmod.8.gz
/usr/share/man/ca/man8/sss_groupshow.8.gz
/usr/share/man/ca/man8/sss_obfuscate.8.gz
/usr/share/man/ca/man8/sss_seed.8.gz
/usr/share/man/ca/man8/sss_useradd.8.gz
/usr/share/man/ca/man8/sss_userdel.8.gz
/usr/share/man/ca/man8/sss_usermod.8.gz
/usr/share/man/cs/man8/sss_groupdel.8.gz
/usr/share/man/de/man8/sss_groupadd.8.gz
/usr/share/man/de/man8/sss_groupdel.8.gz
/usr/share/man/de/man8/sss_groupmod.8.gz
/usr/share/man/de/man8/sss_groupshow.8.gz
/usr/share/man/de/man8/sss_obfuscate.8.gz
/usr/share/man/de/man8/sss_seed.8.gz
/usr/share/man/de/man8/sss_useradd.8.gz
/usr/share/man/de/man8/sss_userdel.8.gz
/usr/share/man/de/man8/sss_usermod.8.gz
/usr/share/man/es/man8/sss_groupadd.8.gz
/usr/share/man/es/man8/sss_groupdel.8.gz
/usr/share/man/es/man8/sss_groupmod.8.gz
/usr/share/man/es/man8/sss_groupshow.8.gz
/usr/share/man/es/man8/sss_obfuscate.8.gz
/usr/share/man/es/man8/sss_seed.8.gz
/usr/share/man/es/man8/sss_useradd.8.gz
/usr/share/man/es/man8/sss_userdel.8.gz
/usr/share/man/es/man8/sss_usermod.8.gz
/usr/share/man/fr/man8/sss_groupadd.8.gz
/usr/share/man/fr/man8/sss_groupdel.8.gz
/usr/share/man/fr/man8/sss_groupmod.8.gz
/usr/share/man/fr/man8/sss_groupshow.8.gz
/usr/share/man/fr/man8/sss_obfuscate.8.gz
/usr/share/man/fr/man8/sss_seed.8.gz
/usr/share/man/fr/man8/sss_useradd.8.gz
/usr/share/man/fr/man8/sss_userdel.8.gz
/usr/share/man/fr/man8/sss_usermod.8.gz
/usr/share/man/ja/man8/sss_groupadd.8.gz
/usr/share/man/ja/man8/sss_groupdel.8.gz
/usr/share/man/ja/man8/sss_groupmod.8.gz
/usr/share/man/ja/man8/sss_groupshow.8.gz
/usr/share/man/ja/man8/sss_obfuscate.8.gz
/usr/share/man/ja/man8/sss_useradd.8.gz
/usr/share/man/ja/man8/sss_userdel.8.gz
/usr/share/man/ja/man8/sss_usermod.8.gz
/usr/share/man/man8/sss_debuglevel.8.gz
/usr/share/man/man8/sss_obfuscate.8.gz
/usr/share/man/man8/sss_override.8.gz
/usr/share/man/man8/sss_seed.8.gz
/usr/share/man/man8/sssctl.8.gz
/usr/share/man/nl/man8/sss_groupmod.8.gz
/usr/share/man/pt/man8/sss_groupdel.8.gz
/usr/share/man/pt/man8/sss_groupmod.8.gz
/usr/share/man/sv/man8/sss_groupmod.8.gz
/usr/share/man/uk/man8/sss_debuglevel.8.gz
/usr/share/man/uk/man8/sss_groupadd.8.gz
/usr/share/man/uk/man8/sss_groupdel.8.gz
/usr/share/man/uk/man8/sss_groupmod.8.gz
/usr/share/man/uk/man8/sss_groupshow.8.gz
/usr/share/man/uk/man8/sss_obfuscate.8.gz
/usr/share/man/uk/man8/sss_override.8.gz
/usr/share/man/uk/man8/sss_seed.8.gz
/usr/share/man/uk/man8/sss_useradd.8.gz
/usr/share/man/uk/man8/sss_userdel.8.gz
/usr/share/man/uk/man8/sss_usermod.8.gz
/usr/share/man/uk/man8/sssctl.8.gz

Changelog

2019-03-27 - Michal Židek <mzidek@redhat.com> - 2.1.0-2
- Resolves: upstream#3867 - [RFE] Need an option in SSSD so that it will skip
GPOs that have groupPolicyContainers unreadable
by SSSD.
- CVE-2018-16838
2019-03-27 - Michal Židek <mzidek@redhat.com> - 2.1.0-1
- Update to latest released upstream version
- https://docs.pagure.org/SSSD.sssd/users/relnotes/notes_2_1_0.html
2019-02-13 - Sinny Kumari <skumari@redhat.com> - 2.0.0-9
- Resolves: rhbz#1667444 -  sssd: make python3-sssdconfig as suggest
2019-02-13 - Adam Williamson <awilliam@redhat.com> - 2.0.0-8
- Resolves: rhbz#1676946 - startup fail with status NOTIMPLEMENTED
2019-02-03 - Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2018-12-12 - Adam Williamson <awilliam@redhat.com> - 2.0.0-6
- Resolves: rhbz#1654537 - sbus: use 120 second default timeout
- Backport two other patches from master to fix build with recent krb5
2018-11-07 - Michal Židek <mzidek@redhat.com> - 2.0.0-5
- Resolves: rhbz#1629737 - sssd: Remove python2 (sub)packages from Fedora 30+
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-4
- Resolves: upstream#3821 - crash related to sbus_router_destructor()
- Resolves: upstream#3810 - sbus2: fix memory leak in sbus_message_bound_ref
- Resolves: upstream#3819 - sssd only sets the SELinux login context if it
differs from the default
- Resolves: upstream#3807 - The sbus codegen script relies on "python" which
might not be available on all distributions
- Resolves: upstream#3820 - sudo: search with lower cased name for case
insensitive domains
- Resolves: upstream#3701 - [RFE] Allow changing default behavior of SSSD from
an allow-any default to a deny-any default when it
can't find any GPOs to apply to a user login.
- Resolves: upstream#3828 - Invalid domain provider causes SSSD to abort
startup
- Resolves: upstream#3500 - Make sure sssd is a replacement for pam_pkcs11
also for local account authentication
- Resolves: upstream#3812 - sssd 2.0.0 segfaults on startup
- Resolves: upstream#3826 - Remove references of sss_user/group/add/del
commands in man pages since local provider is
deprecated
- Resolves: upstream#3827 - SSSD should log to syslog if a domain is not
started due to a misconfiguration
- Resolves: upstream#3830 - Printing incorrect information about domain with
sssctl utility
- Resolves: upstream#3489 - p11_child should work wit openssl1.0+
- Resolves: upstream#3750 - [RFE] man 5 sssd-files should mention necessary
changes in nsswitch.conf
- Resovles: upstream#3650 - RFE: Require smartcard authentication
- Resolves: upstream#3334 - sssctl config-check does not check any special
characters in domain name of domain section
- Resolves: upstream#3849 - Files: The files provider always enumerates
which causes duplicate when running getent passwd
- Related: upstream#3855 - session not recording for local user when groups
defined
- Resolves: upstream#3802 - Reuse sysdb_error_to_errno() outside sysdb
- Related: upstream#3493 - Remove the pysss.local interface
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-3
- Resolves: rhbz#1622760 - Console login as FreeIPA domain user fails in
current Fedora Rawhide / 29
2018-08-29 - Michal Židek <mzidek@redhat.com> - 2.0.0-2
- Fix linking issues

See Also

Package Description
sssd-winbind-idmap-2.1.0-2.fc31.x86_64.rpm SSSD's idmap_sss Backend for Winbind
ssss-0.5-21.fc30.2.x86_64.rpm Shamir's secret sharing scheme
sstp-client-1.0.11-12.fc30.i686.rpm Secure Socket Tunneling Protocol(SSTP) Client
sstp-client-1.0.11-12.fc30.x86_64.rpm Secure Socket Tunneling Protocol(SSTP) Client
sstp-client-devel-1.0.11-12.fc30.i686.rpm Development files for sstp-client
sstp-client-devel-1.0.11-12.fc30.x86_64.rpm Development files for sstp-client
st-0.8.1-4.fc30.x86_64.rpm A simple terminal implementation for X
st-user-0.8.1-4.fc30.x86_64.rpm Sources and tools for user configuration of st
staden-io_lib-1.12.4-16.fc30.i686.rpm General purpose library to handle gene sequencing machine trace files
staden-io_lib-1.12.4-16.fc30.x86_64.rpm General purpose library to handle gene sequencing machine trace files
staden-io_lib-devel-1.12.4-16.fc30.i686.rpm Development files for staden-io_lib
staden-io_lib-devel-1.12.4-16.fc30.x86_64.rpm Development files for staden-io_lib
stage-4.1.1-23.fc30.i686.rpm A 2.5D multi-robot simulator
stage-4.1.1-23.fc30.x86_64.rpm A 2.5D multi-robot simulator
stage-devel-4.1.1-23.fc30.i686.rpm Header files and libraries for Stage
Advertisement
Advertisement