qt5-qtwebengine-freeworld-5.10.1-4.fc29.x86_64.rpm


Advertisement

Description

qt5-qtwebengine-freeworld - Qt5 - QtWebEngine components (freeworld version)

Distribution: Fedora Rawhide
Repository: RPM Fusion Free x86_64
Package name: qt5-qtwebengine-freeworld
Package version: 5.10.1
Package release: 4.fc29
Package architecture: x86_64
Package type: rpm
Installed size: 98.98 MB
Download size: 32.75 MB
Official Mirror: download1.rpmfusion.org
Qt5 - QtWebEngine components (freeworld version). This version is compiled with support for patent-encumbered codecs enabled.

Requires

Provides

  • bundled(SMHasher) = 0-0.1.svn147
  • bundled(angle) = 2422
  • bundled(boringssl)
  • bundled(brotli)
  • bundled(chromium) = 61.0.3163.140
  • bundled(dmg_fp)
  • bundled(dynamic_annotations) = 4384
  • bundled(fdlibm) = 5.3
  • bundled(hunspell) = 1.6.0
  • bundled(iccjpeg)
  • bundled(khronos_headers)
  • bundled(leveldb) = 1.20
  • bundled(libXNVCtrl) = 302.17
  • bundled(libjingle)
  • bundled(libsrtp) = 2.1.0
  • bundled(libxml2) = 2.9.4
  • bundled(libxslt) = 1.1.29
  • bundled(libyuv) = 1658
  • bundled(modp_b64)
  • bundled(mojo)
  • bundled(mozilla_security_manager) = 1.9.2
  • bundled(nsURLParsers)
  • bundled(openmax_dl) = 1.0.2
  • bundled(ots)
  • bundled(protobuf) = 3.0.0-0.1.beta3
  • bundled(qcms) = 4
  • bundled(sfntly)
  • bundled(skia)
  • bundled(sqlite) = 3.20
  • bundled(superfasthash) = 0
  • bundled(symbolize)
  • bundled(usrsctp)
  • bundled(v8) = 6.1.534.44
  • bundled(valgrind.h)
  • bundled(webrtc) = 90
  • bundled(x86inc)
  • bundled(xdg-mime)
  • bundled(xdg-user-dirs) = 0.10
  • config(qt5-qtwebengine-freeworld) = 5.10.1-4.fc29
  • libQt5WebEngine.so.5()(64bit)
  • libQt5WebEngine.so.5(Qt_5)(64bit)
  • libQt5WebEngine.so.5(Qt_5.0)(64bit)
  • libQt5WebEngine.so.5(Qt_5.1)(64bit)
  • libQt5WebEngine.so.5(Qt_5.10)(64bit)
  • libQt5WebEngine.so.5(Qt_5.10.1_PRIVATE_API)(64bit)
  • libQt5WebEngine.so.5(Qt_5.2)(64bit)
  • libQt5WebEngine.so.5(Qt_5.3)(64bit)
  • libQt5WebEngine.so.5(Qt_5.4)(64bit)
  • libQt5WebEngine.so.5(Qt_5.5)(64bit)
  • libQt5WebEngine.so.5(Qt_5.6)(64bit)
  • libQt5WebEngine.so.5(Qt_5.7)(64bit)
  • libQt5WebEngine.so.5(Qt_5.8)(64bit)
  • libQt5WebEngine.so.5(Qt_5.9)(64bit)
  • libQt5WebEngineCore.so.5()(64bit)
  • libQt5WebEngineCore.so.5(Qt_5)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.0)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.1)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.10)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.10.1_PRIVATE_API)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.2)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.3)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.4)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.5)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.6)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.7)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.8)(64bit)
  • libQt5WebEngineCore.so.5(Qt_5.9)(64bit)
  • libQt5WebEngineWidgets.so.5()(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.0)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.1)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.10)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.10.1_PRIVATE_API)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.2)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.3)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.4)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.5)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.6)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.7)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.8)(64bit)
  • libQt5WebEngineWidgets.so.5(Qt_5.9)(64bit)
  • qt5-qtwebengine-freeworld = 5.10.1-4.fc29
  • qt5-qtwebengine-freeworld(x86-64) = 5.10.1-4.fc29

    Install Howto

    1. Download the latest rpmfusion-free-release-stable rpm from
      http://download1.rpmfusion.org/free/fedora/
    2. Install rpmfusion-free-release-stable rpm:
      # rpm -Uvh rpmfusion-free-release-stable*rpm
    3. Install qt5-qtwebengine-freeworld rpm package:
      # dnf --enablerepo=rpmfusion-free-rawhide install qt5-qtwebengine-freeworld

    Files

    • /etc/ld.so.conf.d/qt5-qtwebengine-freeworld-x86_64.conf
    • /usr/lib/.build-id/
    • /usr/lib/.build-id/b2/c0a9b69ef0e8e0670789995c69151ca7ddf625
    • /usr/lib/.build-id/f6/630e65d9275d9847faaffb6ea777d8f8f93550
    • /usr/lib/.build-id/f9/239c019b148cd1b67ad52d59de7ff3382cf444
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngine.so.5
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngine.so.5.10
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngine.so.5.10.1
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineCore.so.5
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineCore.so.5.10
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineCore.so.5.10.1
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineWidgets.so.5
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineWidgets.so.5.10
    • /usr/lib64/qt5-qtwebengine-freeworld/libQt5WebEngineWidgets.so.5.10.1
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.Chromium
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.GPL2
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.GPL3
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.GPL3-EXCEPT
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.GPLv3
    • /usr/share/licenses/qt5-qtwebengine-freeworld/LICENSE.LGPL3
    • /usr/share/licenses/qt5-qtwebengine-freeworld/qtwebengine-3rdparty.qdoc

    Changelog

    2018-03-18 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.10.1-4 - Fix (from 5.9.5) for incomplete, ineffective fix for CVE-2018-6033 in 5.10.1

    2018-03-17 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.10.1-3 - Forward-port security backports from 5.9.5 LTS (up to Chromium 65.0.3325.146)

    2018-03-01 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.10.1-2 - Drop -fabi-version=11 workaround, gcc-8.0.1-0.16.fc28 should fix this

    2018-02-18 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.10.1-1 - Update to 5.10.1 - Rediff (unfuzz) no-sse2 patch - Workaround FTBFS with GCC 8, build with -fabi-version=11 on F28+ (rh#1545918) - Reenable system libvpx on F28+, Rawhide (future F28) has libvpx 1.7.0 now - Fix build with FFmpeg 3.5 (apply conditionally because it breaks older FFmpeg) - Disable use_jumbo_build on aarch64

    2017-12-30 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.10.0-1 - Update to 5.10.0 - Update version numbers of bundled stuff - Drop support for Fedora < 26 (in particular, WEBENGINE_CONFIG F25 workarounds) - Drop qt57 patch, support for Qt 5.7 was completely dropped upstream - Use QMAKE_EXTRA_ARGS instead of the removed WEBENGINE_CONFIG - Rebase linux-pri, system-nspr-prtime, system-icu-utf, no-sse2, skia-neon and gn-bootstrap-verbose patches - In particular, restore the removed V8 x87 backend in the no-sse2 patch - Disable system libvpx support for now, requires unreleased libvpx (1.6.2+) - Add new BuildRequires: flex (required) and pkgconfig(lcms2) (unbundled) - Forward-port missing parts of 5.9 ICU>=59 build fix (QTBUG-60886, QTBUG-65090) - Drop support for Unicode "aspirational scripts", fixes #error with ICU >= 60

    2017-11-26 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.9.3-1 - Update to 5.9.3

    2017-10-14 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.9.2-1 - Update to 5.9.2 - Add BuildRequires: qt5-qtquickcontrols2-devel for the examples - Rebase linux-pri patch - Drop qt57 and qtbug-61521 patches, fixed upstream - arm-fpu-fix patch: Drop the host tools hunk added in 5.9.0-2, fixed upstream - linux-pri patch: Do not call the Chromium unbundling script on re2, QtWebEngine now auto-detects and uses the system re2 out of the box - Drop system-re2 patch (patching the no longer used unbundle/re2.gn), the QtWebEngine re2/BUILD.gn is already correct - Explicitly force use_system_re2, the autodetection does not work on F25 - Fix FTBFS with Qt 5.7

    2017-08-31 - RPM Fusion Release Engineering <kwizart@rpmfusion.org> - 5.9.1-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

    2017-07-27 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.9.1-2 - Rebuild for Qt 5.9.1

    2017-07-02 - Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.9.1-1 - Update to 5.9.1 - Rebase qtbug-61521 patch (drop the parts that are already in 5.9.1) - Drop backported GN aarch64 patches already included in 5.9.1 - no-sse2 patch: Upstream added 2 examples, add -Wl,-rpath-link to them too

    Advertisement
    Advertisement