sublime_text-3.0.3143-2.fc28.i686.rpm


Advertisement

Description

sublime_text - Sublime Text 3

Distribution: Fedora Rawhide
Repository: Russian Fedora Nonfree x86_64
Package name: sublime_text
Package version: 3.0.3143
Package release: 2.fc28
Package architecture: i686
Package type: rpm
Installed size: 21.62 MB
Download size: 8.57 MB
Official Mirror: mirror.yandex.ru
Sublime Text 3 for GNU/Linux is a sophisticated text editor for code, markup and prose.

Alternatives

Provides

  • application()
  • application(sublime_text.desktop)
  • mimehandler(text/calendar)
  • mimehandler(text/cmd)
  • mimehandler(text/css)
  • mimehandler(text/csv)
  • mimehandler(text/html)
  • mimehandler(text/javascript)
  • mimehandler(text/php)
  • mimehandler(text/plain)
  • mimehandler(text/tab-separated-values)
  • mimehandler(text/x-asm)
  • mimehandler(text/x-c)
  • mimehandler(text/x-c++hdr)
  • mimehandler(text/x-c++src)
  • mimehandler(text/x-fortran)
  • mimehandler(text/x-java-source)
  • mimehandler(text/x-pascal)
  • mimehandler(text/x-uuencode)
  • mimehandler(text/x-vcalendar)
  • mimehandler(text/x-vcard)
  • mimehandler(text/x-xsrc)
  • mimehandler(text/xml)
  • mimehandler(text/yaml)
  • sublime_text = 3.0.3143-2.fc28
  • sublime_text(x86-32) = 3.0.3143-2.fc28
  • sublimetext = 3.0.3143-2.fc28
  • sublimetext3 = 3.0.3143-2.fc28

Conflicts

  • sublime-text

Obsoletes

  • sublimetext < 3.0.3143-2.fc28
  • sublimetext3 < 3.0.3143-2.fc28

    Install Howto

    1. Download the latest russianfedora-nonfree-release rpm from
      http://mirror.yandex.ru/fedora/russianfedora/russianfedora/nonfree/fedora/development/rawhide/x86_64/os/
    2. Install russianfedora-nonfree-release rpm:
      # rpm -Uvh russianfedora-nonfree-release*rpm
    3. Install sublime_text rpm package:
      # dnf --enablerepo=russianfedora-nonfree-rawhide install sublime_text

    Files

    • /opt/sublime_text/changelog.txt
    • /opt/sublime_text/crash_reporter
    • /opt/sublime_text/plugin_host
    • /opt/sublime_text/python3.3.zip
    • /opt/sublime_text/sublime.py
    • /opt/sublime_text/sublime_plugin.py
    • /opt/sublime_text/sublime_text
    • /opt/sublime_text/Packages/ASP.sublime-package
    • /opt/sublime_text/Packages/ActionScript.sublime-package
    • /opt/sublime_text/Packages/AppleScript.sublime-package
    • /opt/sublime_text/Packages/Batch File.sublime-package
    • /opt/sublime_text/Packages/C#.sublime-package
    • /opt/sublime_text/Packages/C++.sublime-package
    • /opt/sublime_text/Packages/CSS.sublime-package
    • /opt/sublime_text/Packages/Clojure.sublime-package
    • /opt/sublime_text/Packages/Color Scheme - Default.sublime-package
    • /opt/sublime_text/Packages/Color Scheme - Legacy.sublime-package
    • /opt/sublime_text/Packages/D.sublime-package
    • /opt/sublime_text/Packages/Default.sublime-package
    • /opt/sublime_text/Packages/Diff.sublime-package
    • /opt/sublime_text/Packages/Erlang.sublime-package
    • /opt/sublime_text/Packages/Go.sublime-package
    • /opt/sublime_text/Packages/Graphviz.sublime-package
    • /opt/sublime_text/Packages/Groovy.sublime-package
    • /opt/sublime_text/Packages/HTML.sublime-package
    • /opt/sublime_text/Packages/Haskell.sublime-package
    • /opt/sublime_text/Packages/Java.sublime-package
    • /opt/sublime_text/Packages/JavaScript.sublime-package
    • /opt/sublime_text/Packages/LaTeX.sublime-package
    • /opt/sublime_text/Packages/Language - English.sublime-package
    • /opt/sublime_text/Packages/Lisp.sublime-package
    • /opt/sublime_text/Packages/Lua.sublime-package
    • /opt/sublime_text/Packages/Makefile.sublime-package
    • /opt/sublime_text/Packages/Markdown.sublime-package
    • /opt/sublime_text/Packages/Matlab.sublime-package
    • /opt/sublime_text/Packages/OCaml.sublime-package
    • /opt/sublime_text/Packages/Objective-C.sublime-package
    • /opt/sublime_text/Packages/PHP.sublime-package
    • /opt/sublime_text/Packages/Pascal.sublime-package
    • /opt/sublime_text/Packages/Perl.sublime-package
    • /opt/sublime_text/Packages/Python.sublime-package
    • /opt/sublime_text/Packages/R.sublime-package
    • /opt/sublime_text/Packages/Rails.sublime-package
    • /opt/sublime_text/Packages/Regular Expressions.sublime-package
    • /opt/sublime_text/Packages/RestructuredText.sublime-package
    • /opt/sublime_text/Packages/Ruby.sublime-package
    • /opt/sublime_text/Packages/Rust.sublime-package
    • /opt/sublime_text/Packages/SQL.sublime-package
    • /opt/sublime_text/Packages/Scala.sublime-package
    • /opt/sublime_text/Packages/ShellScript.sublime-package
    • /opt/sublime_text/Packages/TCL.sublime-package
    • /opt/sublime_text/Packages/Text.sublime-package
    • /opt/sublime_text/Packages/Textile.sublime-package
    • /opt/sublime_text/Packages/Theme - Default.sublime-package
    • /opt/sublime_text/Packages/Vintage.sublime-package
    • /opt/sublime_text/Packages/XML.sublime-package
    • /opt/sublime_text/Packages/YAML.sublime-package
    • /usr/bin/sublime_text
    • /usr/lib/.build-id/
    • /usr/lib/.build-id/2c/d301c320713e70a7bf96fcc0cd350f9734f407
    • /usr/lib/.build-id/92/06a3efab80b585d7fecf9b1bb44d9d4420b883
    • /usr/lib/.build-id/c2/9d8c531b56dcb24f0245bbf7539e838f53adfa
    • /usr/share/applications/sublime_text.desktop
    • /usr/share/icons/hicolor/128x128/apps/sublime_text.png
    • /usr/share/icons/hicolor/16x16/apps/sublime_text.png
    • /usr/share/icons/hicolor/256x256/apps/sublime_text.png
    • /usr/share/icons/hicolor/32x32/apps/sublime_text.png
    • /usr/share/icons/hicolor/48x48/apps/sublime_text.png

    Changelog

    2017-10-28 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3143-2 - Use alternatives to provide /usr/bin/sublime_text binary.

    2017-09-14 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3143-1.R - Updated to 3.0.3143 (release).

    2016-09-24 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3126-1.R - Updated to 3.0.3126.

    2016-09-22 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3124-1.R - Updated to 3.0.3124.

    2016-07-06 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3114-2.R - Updated desktop file. Fixed issue with Gnome 3. Updated Requires.

    2016-05-13 - Arkady L. Shane <ashejn@russianfedora.pro> - 3.0.3114-1.R - update to 3.0.3114

    2016-02-15 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3103-3.R - Fixed file list owned by package.

    2016-02-12 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3103-2.R - Fixed SPEC. Updated to 3.0.3103-2.

    2016-02-11 - Vitaly Zaitsev <vitaly@easycoding.org> - 3.0.3103-1.R - Updated SPEC to latest Sublime Text 3 version.

    2015-11-19 - Arkady L. Shane <ashejn@russiandedora.pro> - 3.0.3083-2.R - fix issue with copyrights http://github.com/RussianFedora/sublime_text/issues/1 - rename spec - define version in Obsoletes

    Advertisement
    Advertisement